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Introduction 

Overview 

The Eye4Software Coordinate Calculator is a desktop tool to convert ( GPS ) coordinates between different 
geodetic datums and / or coordinate systems (or map projections). The software can be used to transform a single 
coordinate, or a batch of coordinates read from a comma separated file. The software is shipped with a database 
containing over 1400 different map projections around the world. It is possible to modify the coordinate systems, 
reference ellipsoids and geodetic datum definitions stored in the database. You can also create user defined 
coordinate systems, reference ellipsoids and geodetic datum definitions, so you can always extend the database in 
case a datum or grid is missing.  

The following calculations are supported:  

 Convert coordinates from latitude / longitude to a specific chart projection; 

 Convert coordinates from latitude / longitude to latitude / longitude, transforming to another geodetic 
datum; 

 Convert coordinates from specific coordinate system to latitude/longitude; 

 Convert coordinates from one coordinate system to another; 

 Convert coordinates between different latitude / longitude formats. 

Supported Projections 

For the conversion between different coordinate systems, the following map projections are available:  

 Lambert Conformal Conic (LCC) 1SP projection; 

 Lambert Conformal Conic (LCC) 2SP projection; 

 Lambert Equal Area Conic projection; 

 Transverse Mercator projection; 

 Oblique Mercator projection; 

 Hotine Oblique Mercator projection; 

 Swiss Oblique Mercator projection; 

 Oblique Stereographic projection; 

 Polar Stereographic projection; 

 Albers Equal Area Conic projection; 

 Cassini Soldner projection; 

 Mercator projection 1SP; 

 Mercator projection 2SP; 

 Polyconic projection; 

 Gauss Kruger projection; 

 Universal Transverse Mercator (UTM) projection; 

 Mollweide projection; 

 Eckert IV projection; 

 Eckert VI projection; 

 Krovak projection. 

 

 

 

 

 



Requirements 

The software will run on the following platforms: 
 
Server Platforms: 

 Windows 2000 Server; 

 Windows 2003 Server; 

 Windows 2008 Server; 

 Windows 2003 R2 Server; 

 Windows 2008 R2 Server. 

 
Desktop Platforms: 

 Windows 2000 Professional; 

 Windows XP; 

 Windows Vista; 

 Windows 7. 

Installation 

The software can be installed using the installer that can be downloaded from the download section of this 
website. The installer will guide you through the installation process, the software and the database are copieed 
and the program menu items are created. After the installation the software can be used directly.  
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Getting Started 

Main Window 

After starting the application, the following window is displayed, which is the main window of the application:  

 

In this window you:  

 Select the source datum or grid definition; 

 Select the destination datum or grid definition; 

 Can show the source or destination coordinates in Google Maps using your webbrowser; 

 Select the display format for Latitude and Longitude positions; 

 Can perfom the calculations. 

 

Source Coordinates Section 

Source Grid 

In this field, the name of the source map grid is displayed. When the source coordinate is in Latitude / Longitude, 
the text: "Geographic Longitude / Latitude" is displayed here. To set the source coordinate to Latitude / Longitude, 
you have to select a Geodetic Datum instead of a Map Grid.  

Source Datum 

In this field, the name of the source geodetic datum is displayed. When a map grid is selected, this field displays 
the map datum used in this map grid. To set the source coordinate to a Northing / Easting projection, you have to 
select a Map Grid instead of a Geodetic Datum.  



Source Latitude / Northing 

Depending on whether you selected a map grid or not, this field is used to enter the source Northing or Latitude 
coordinate. When using a map grid, the units of the Y-axis are displayed ( for instance: meters, feet, links etc... ).  

Source Longitude / Easting 

Depending on whether you selected a map grid or not, this field is used to enter the source Easting or Longitude 
coordinate. When using a map grid, the units of the X-axis are displayed ( for instance: meters, feet, links etc... ).  

Map Button 

When you click the "Map..." button, the software will convert the source coordinate entered to a WGS84 based 
Latitude / Longitude format, and displays this position as a marker in a Google Maps webpage. This way you can 
check whether the correct coordinates have been entered.  

Source Latitude / Longitude Format 

In Latitude and Longitude mode, 3 radio buttons are shown, you can use these buttons to select the Latitude / 
Longitude format:  

 Decimal Degrees; 

 Degrees, Decimal Minutes; 

 Degrees, Minutes, Seconds. 

When a map grid is selected, these buttons are hidden, and the coordinates are displayed in Northing and Easting 
units.  

 

Destination Coordinates Section 

Destination Grid 

In this field, the name of the destination map grid is displayed. When the destination coordinate is in Latitude / 
Longitude, the text: "Geographic Longitude / Latitude" is displayed here. To set the destination coordinate to 
Latitude / Longitude, you have to select a Geodetic Datum instead of a Map Grid.  

Destination Datum 

In this field, the name of the destination geodetic datum is displayed. When a map grid is selected, this field 
displays the map datum used in this map grid. To set the destination coordinate to a Northing / Easting projection, 
you have to select a Map Grid instead of a Geodetic Datum.  

Destination Latitude / Northing 

Depending on whether you selected a map grid or not, this field is used to display the calculated Northing or 
Latitude coordinate. When using a map grid, the units of the Y-axis are displayed ( for instance: meters, feet, links 
etc... ).  

Destination Longitude / Easting 

Depending on whether you selected a map grid or not, this field is used to display the calculated Easting or 
Longitude coordinate. When using a map grid, the units of the X-axis are displayed ( for instance: meters, feet, 
links etc... ).  



Map Button 

When you click the "Map..." button, the software will convert the destination coordinate calculated to a WGS84 
based Latitude / Longitude format, and displays this position as a marker in a Google Maps webpage. This way 
you can check whether the correct coordinates have been calculated.  

Destination Latitude / Longitude Format 

In Latitude and Longitude mode, 3 radio buttons are shown, you can use these buttons to select the Latitude / 
Longitude format:  

 Decimal Degrees; 

 Degrees, Decimal Minutes; 

 Degrees, Minutes, Seconds. 

When a map grid is selected, these buttons are hidden, and the coordinates are displayed in Northing and Easting 
units.  

 

Main screen buttons 

Transform 

Using the transform button you can perform the actual map grid or map datum conversion. The source 
coordinates are always used as input, and the calculated result is displayed in the destination coordinates section  

Swap 

When clicking the "Swap" button, all the values of the source and destination coordinates sections are swapped. 
This makes it easy to perform a reverse calculation without the need to enter all information again.  

Clear 

By pressing the "Clear" button, all fields and settings are reset to their defaults. If not saved, your current settings 
will be lost.  

Exit 

Closes the application after saving the current settings.  

 

Main Screen Menu 

"File" => "Save Configuration" 

It is possible to save your current configuration and coordinates at any time using this command. A file selection 
will appear asking you for a file name to save the information to. You can retrieve this "snapshot" of your settings 
at any time using the "File" => "Load Configuration" menu item.  

"File" => "Load Configuration" 

Use this option to load a previously saved "snapshot" of your configuration.  



"Tools" => "Preferences" => "Manage Grids" 

Allows you to add, edit or delete map grid definitions. Please see the "Manage Grids" section of this document for 
more information.  

"Tools" => "Preferences" => "Manage Datums" 

Allows you to add, edit or delete geodetic datum definitions. Please see the "Manage Datums" section of this 
document for more information.  

"Tools" => "Preferences" => "Manage Ellipsoids" 

Allows you to add, edit or delete reference ellipsoid definitions. Please see the "Manage Ellipsoids" section of this 
document for more information.  

"Tools" => "Preferences" => "Manage Countries" 

Allows you to add, edit or delete country / region definitions. Please see the "Manage Countries" section of this 
document for more information.  

"Tools" => "Calculate Distance" 

You can use this tool to calculate the distance between 2 coordinates. It is also possible to calculate the distance 
between a coordinate in Latitude / Longitude and Easting / Northing. Before performing the calculation, both 
coordinates will be converted to WGS Latitude / Longitude positions. The software does not use great circle 
calculations, but uses the Vincenty formule which gives far more reliable results.  

"Help" => "About" 

This window displays version and licensing information. After purchasing, you can enter your registrationcode 
here.  
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Performing Datum Transformations 

To perform a datum transformation, you need to specify a source and destination datum in the main window. This 
can be done by pressing the "Select..." button behind the "Source Datum" and "Destination Datum" fields. The 
database shipped with the application contains almost any geodetic datum on the world. For a complete list of the 
datums shipped with the current version of the Coordinate Calculator, click here. In case the required geodetic 
datum is missing, you can add this one by yourself. For more info on adding, deleting and editing map datums, 
see the "Manage Datums" section of this document.  

To demonstrate a simple datum conversion, please follow the following steps:  

 Start the application; 

 In the source coordinate section, click the "Select..." button next to the "Source Datum" field; 

 In the list, select "WGS84" and click "OK"; 

 In the destination coordinate section, click the "Select..." button next to the "Destination Datum" field; 

 In the list, select "European 1950" and click "OK"; 

 For both coordinates, select the "dd mm sss" format; 

 Enter the source coordinates: 51°54'00.00" N and 004°24'00.00" E; 

 Click the "Transform" button; 

Ready, the result should be the same as displayed by the image below:  
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Performing Map Grid Transformations 

There are 3 ways you can perform map grid transformations:  

 From one map grid to another; 

 From unprojected ( Latitude / Longitude ) coordinates to map grid coordinates ( Northing / Easting );  

 From map grid coordinates ( Northing / Easting ) to unprojected ( Latitude / Longitude ) coordinates;  

To convert from one map grid to another, you have to select a map grid in both the source and destination 
coordinates sections. The map grid can be selected by pressing the "Select" button next to the "Source Grid" or 
"Destination Grid" fields. When converting from unprojected to a map projection, select a map datum for the 
source coordinates, for the destination coordinates, select a map grid. The database shipped with the application, 
contains almost any map grid used around. For a complete list of the map grids shipped with the current version 
of the Coordinate Calculator, click here.  

To demonstrate a simple grid conversion ( WGS84 unprojected to RDNAP), please follow the following steps:  

 Start the application; 

 In the source coordinate section, click the "Select..." button next to the "Source Datum" field; 

 In the list, select "WGS84" and click "OK"; 

 In the destination coordinate section, click the "Select..." button next to the "Destination Grid" field; 

 In the list, select "Netherlands - RDNAP" and click "OK"; 

 For the source coordinates, select the "dd mm sss" format; 

 Enter the source coordinates: 51°54'00.00" N and 004°24'00.00" E; 

 Click the "Transform" button; 

Ready, the result should be the same as displayed by the image below:  
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To demonstrate a conversion from this map grid to unprojected ( WGS84 ), just click the "Swap" button and click 
"Transform".  

 

Managing The Database 

Manage Ellipsoids 

Introduction 

To open the "Manage Ellipsoids" window, select "Tools" => "Preferences" => "Manage Ellipsoids" from the menu. 
Using this window, you will be able to view, delete or modify existing ellipsoid definitions, or to add your own. For 
a list of ellisoids that are already in the database, click here.  

 

Ellipsoid List 

When clicking an item in the list, its parameters are displayed below the list. You can edit these parameters by 
clicking the "Modify" button.  

Deleting an ellipsoid 

You can delete an ellipsoid definition, by selecting an item from the list and clicking the button "Delete". The 
software will show a popup to confirm that you are sure you want to delete. Please note that you cannot delete 
ellipsoids that are used in a datum definition.  

Modifying an ellipsoid 

http://localhost/products/coordinatecalculator/ellipsoids


You can modify an ellipsoid by clicking the "Modify" button after you selected an ellipsoid from the list. After 
clicking the button, the "OK" button text will change to "Save". Clicking the "Save" button will save the 
modifications, clicking "Cancel" will keep the old data.  

Adding an ellipsoid 

To add a new ellipsoid definition, click the "Add" button. When adding a new definition, it is required to specify a 
name for this ellipsoid, otherwise it cannot be saved. Other required fields are "Semi-Major Axis" and "Inverse 
Flattening". The "Eccentricity Squared" value is calculated, but not stored to the database. Click the "Save" button 
to store the newly created ellipsoid, by clicking cancel the input is ignored and you will return to the list.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Manage Datums 

Introduction 

To open the "Manage Datums" window, select "Tools" => "Preferences" => "Manage Datums" from the menu. 
Using this window, you will be able to view, delete or modify existing datum definitions, or to add your own. For a 
list of datums that are already in the database, click here.  

 

Datum List 

When clicking an item in the list, its parameters are displayed below the list. You can edit these parameters by 
clicking the "Modify" button.  

Deleting a datum 

You can delete an datum definition, by selecting an item from the list and clicking the button "Delete". The 
software will show a popup to confirm that you are sure you want to delete. Please note that you cannot delete 
datums that are used in a grid definition.  

http://localhost/products/coordinatecalculator/datums


Modifying a datum 

You can modify a datum by clicking the "Modify" button after you selected a datum from the list. After clicking the 
button, the "OK" button text will change to "Save". Clicking the "Save" button will save the modifications, clicking 
"Cancel" will keep the old data.  

Adding a datum 

To add a new datum definition, click the "Add" button. When adding a new definition, it is required to specify a 
name for this datum, as well as the ellipsoid used. Other fields are optional and are defaulting to 0.0 when not 
used. Please note that the X,Y and Z translations have to be entered in Meters, the X,Y and Z rotations are 
entered in arc seconds. If you have a datum definition that uses radians, you have to convert from radians to 
arcseconds first: 1 radian = 206 264.806 arcseconds. Click the "Save" button to store the newly created datum, by 
clicking cancel the input is ignored and you will return to the list.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Manage Grids 

Introduction 

To open the "Manage Grids" window, select "Tools" => "Preferences" => "Manage Grids" from the menu. Using 
this window, you will be able to view, delete or modify existing grids definitions, or to add your own. For a list of 
map grids that are already in the database, click here.  

 

Grid List 

http://localhost/products/coordinatecalculator/grids


When clicking an item in the list, its parameters are displayed below the list. You can edit these parameters by 
clicking the "Modify" button. The map grid list can be sorted by clicking on the list columns. You can sort the list 
by country, grid name and geodetic datum used. A map grid definition is displayed by the flag of the country 
where it applies to. If a grid can be used in multiple countries / regions, instead of a flag, a globe is displayed.  

Deleting a grid 

You can delete an datum definition, by selecting an item from the list and clicking the button "Delete". The 
software will show a popup to confirm that you are sure you want to delete. When clicking "Yes" the grid has been 
deleted.  

Modifying a grid 

You can modify a grid by clicking the "Modify" button after you selected a grid from the list. After clicking the 
button, the "OK" button text will change to "Save". Clicking the "Save" button will save the modifications, clicking 
"Cancel" will keep the old data.  

Adding a grid 

To add a new grid definition, click the "Add" button. When adding a new definition, it is required to specify a name 
for this grid, as well as the datum and projection used. Depending on the chosen projection, the input fields are 
enabled or disabled. The table below shows what fields are required for the different projections:  

Projection SCALE FALSE_N FALSE_E LAT_0 LON_0 PAR_1 PAR_2 AZI RECTGRD 

Lambert Conformal Conic 1 SP x x x x x - - - - 

Lambert Conformal Conic 2 SP - x x x x x x - - 

Lambert Azimuthal Equal Area - x x x x x x - - 

Transverse Mercator x x x x x - - - - 

Oblique Stereographic x x x x x - - - - 

Polar Stereographic - x x x x - - - - 

Oblique Mercator - x x x x - - - - 

Hotine Oblique Mercator - x x x x - - x x 

Swiss Oblique Mercator - x x x x - - - - 

Albers Equal Area Conic - x x x x x x - - 

Mercator 1SP x x x x x - - - - 

Mercator 2SP - x x x x x - - - 

Mollweide - x x - x - - - - 

Eckert IV - x x - x - - - - 

Eckert VI - x x - x - - - - 

Cassini - x x x x - - - - 

Krovak x x x x x x - x - 

Selecting a country is not required, but the country can be used to sort lists by country, if the grid does not apply 
to a simple country, just select "Earth", "Europe", "Asia" etc... When you want to use other units for the Northing 
and Easting values calculated ( default is Meters ), you can also select the units to be used. Please note that when 
changing this, you also have to enter the False Northing and False Easting in these units. Units currently supported 
are:  

 

 

 



 Meters 

 Kilometers 

 International Foot 

 British Foot 

 Clarke's Foot 

 Gold Coast Foot 

 Indian Foot 

 British Foot (Sears) 

 U.S. Survey Foot 

 Link 

 Clarke's Link 

 British Link (Sears) 

 U.S. Survey Link 

 Statute Mile 

 U.S. Survey Mile 

 Chain 

 Clarke's Chain 

 British Chain (Sears) 

 U.S. Survey Chain 

Click the "Save" button to store the newly created grid, by clicking cancel the input is ignored and you will return 
to the list.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Manage Countries 

Introduction 

To open the "Manage Countries" window, select "Tools" => "Preferences" => "Manage Countries" from the menu. 
Using this window, you will be able to view, delete or modify existing country / region definitions, or to add your 
own. The use of countries / regions is not required to perform calculations. It is only added to provide a 
mechanism to sort the map grids by the region or country they are used for.  

 

Country 

When clicking an item in the list, its parameters are displayed below the list (country name and flag filename). You 
can edit these parameters by clicking the "Modify" button.  

Deleting a country 

You can delete a country definition, by selecting an item from the list and clicking the button "Delete". The 
software will show a popup to confirm that you are sure you want to delete. Please note that you cannot delete 
countries that are used in a grid definition.  

Modifying a country 

You can modify a country by clicking the "Modify" button after you selected a country from the list. You can for 
instance translate the country name to your own language, or modify previously created regions. The flag 



associated with the country or region can be changed by clicking the "Browse" button. How to add your own 
symbols or flags is described in the "Adding a country" section below. After clicking the button, the "OK" button 
text will change to "Save". Clicking the "Save" button will save the modifications, clicking "Cancel" will keep the old 
data.  

Adding a country 

To add a new country definition, click the "Add" button. When adding a new definition, it is required to specify a 
name for this country. Specifying a symbol or flag for this country is optional, when no image has been specified a 
globe is displayed in the grid list. If you want to add your own symbol, convert this symbol to a 16x16 PNG Image 
file and copy this file to the "Flags" folder in the program directory. You can select a flag or symbol by clicking the 
"Browse" button. The software ships with flags for most countries around. Click the "Save" button to store the 
newly created datum, by clicking cancel the input is ignored and you will return to the list.  

 

 


