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1 Introduction

Eye4Software Hydromagic is an hydrographic survey software tool, which can be used to map areas
using a GPS and echosounder. Use the software to import, view and edit your maps, display your
position and to record depths (create soundings). The software will work with almost any GPS and
echosounder, and can be used on any desktop, laptop or netbook computer running Windows XP(SP2)
or higher.

Some application examples:

    Record depth data using a GPS and echosounder;
    Show your current position and depth on a loaded map;
    Convert your soundings to a regularly spaced XYZ data (DTM);
    Convert your soundings to different file formats;
    Show cross-sections and calculate volumes;
    Design and generate theoretical DTM's (channel design);
    Create depth contours and save them as ESRI shapefiles;
    Add comments, symbols or routes to your maps;
    Perform realtime positioning on research and hydrographic survey vessels;
    Fishing industry, for instance to navigate inside the assigned fishing parcels;
    View GIS features on shapefiles, CAD and S57 (ENC) data;

1.1 Supported Hardware

Supported Hardware

The list below is just an indication, the software will probably work with more models then the ones that
are displayed below.

Supported Echosounders

    NMEA0183 Compatible Echosounders;
    Cee Hydrosystems Ceestar;
    Cee Hydrosystems Ceeducer pro;
    Elac Hydrostar LAZ4300;
    Elac LAZ4100;
    Elac STG 721C;
    Innerspace Technologies 440S;
    Innerspace Technologies 448;
    Innerspace Technologies 449;
    Innerspace Technologies 455;
    Innerspace Technologies 456;
    Knudsen 320 series;
    Navitronic Navisound 2000;
    SyQwest Bathy 500DF;
    SyQwest Bathy 500MF;
    SyQwest Bathy 1500C;
    Ohmex SonarMite;
    Odom DigiTrace;
    Odom EchoTrac DF3200 MK II;

    Simrad EA200 series;
    Simrad EA300 series;
    Simrad EA400 series;
    Simrad EA500 series;
    Simrad EA600 series;
    STN Atlas Deso 11;
    STN Atlas Deso 14;
    STN Atlas Deso 15;
    STN Atlas Deso 17;
    STN Atlas Deso 20;
    STN Atlas Deso 22;
    STN Atlas Deso 25;
    STN Atlas Deso 30;
    STN Atlas Deso 35;
    STN Atlas Deso 350M;
    Reson Navisound 110;
    Reson Navisound 205;
    Reson Navisound 210;
    Reson Navisound 215;
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    Odom EchoTrac MK III;
    Odom EchoTrac CV100;
    Odom EchoTrac CV200;
    Odom EchoTrac CV300;
    Odom EchoTrac CVM;
    Odom HydroTrac;
    Odom HydroTrac II;

    Reson Navisound 420;
    Reson Navisound 630DS;

Supported GPS Receivers

    NMEA0183 Compatible GPS Receivers;
    NMEA0183 Compatible DGPS Receivers;
    NMEA0183 Compatible RTK Receivers;
    Garmin USB GPS receivers using the PVT protocol;
    Trimble RTK Receivers;

Supported Tide Receivers

    MGB Tech MTU821-D;
    MGB Tech MTU821-W;
    Ohmex TidaLite;
    Vyner MK2;

Supported AIS Receivers

    AdvanSea AIS RX-100;
    Digital Yacht AIS100;
    Digital Yacht AIS200PRO;
    Digital Yacht AIS200N2K;
    Digital Yacht ANT200;
    Digital Yacht iAIS;
    EuroNav AIS-2-NMEA;
    EuroNav AIS-2-USB;
    Furuno FA30;
    Icom MXA-5000;
    Nasa AIS Engine 1;
    Nasa AIS Engine 2;
    Nasa AIS Engine 3;
    Smart Radio SR161;
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2 Configuration

2.1 Installation

System Requirements

The software requires a system which is capable of running Microsoft Windows XP SP2 or later. It will
not work on earlier versions of this O.S. The software is build as 32 bit software, and will run on both 32
and 64 bit Windows operating systems.

When you are going to post-process soundings (3D, contour generation, matrix generation etc.), we
recommend a computer with at least a dual-core processor and 2 Gigabyte of free RAM. You will also
need sufficient space on the hard disk to store maps, soundings and matrix files.

Installation

To start the installation, run the setup_hydro.exe downloaded from the website, or from the program CD.
When using Windows Vista or newer operating systems, it is recommended to run the setup program as
Administrator, as shown in the image below:

http://www.eye4software.com/download
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Just follow the steps of the setup program. After setup has completed, the software will start
automatically.

2.2 Activation

Activation

After installation, you can use the software free of charge for a 30 day period. After expiration of this
period, you have to activate the software by entering a key. You can contact our sales department to
obtain a key, or buy one online using credit card, wire transfer or PayPal.

To enter the activation code, select the "About Hydromagic..." option from the "Help" menu. This dialog
shows you whether the software has been activated and the correct version number. Click the "Enter
Code..." button to enter your activation code. After activation the dialog should show: "Registered
Version". 
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2.3 Hardware Configuration

2.3.1 Configuring an NMEA0183 compatible GPS

Introduction

The most important device required for this software to work, is the GPS receiver. At this moment, all
GPS devices with a NMEA-0183 compatible connection are supported. 
The GPS is used to get position, course, speed and information on GPS quality and / or precision.

In order to connect a GPS receiver, you need to have at least one available serial port. If there is no port
available, you can add a serial port by using an USB-to-Serial converter or a NMEA0183 data combiner
equiped with an USB port. When using such a converter, make sure it is connected at the time you are
going to configure the GPS. It is recommended to configure a GPS receiver at NMEA0183 channel #1. In
most scenarios, you only have to select the correct serial port to be used. For a GPS device, it is also
recommended to select the "$GPGGA" and "$GPVTG" options in the filter settings. 

Supported NMEA0183 sentences for GPS devices

Hydromagic is able to decode the following NMEA0183 sentences used by GPS and RTK devices:

Sentence Description

$GPGGA Global Positioning System Fix Data, Time and Position

$GPGLL Geographic Position - Latitude and Longitude

$GPGSA GPS DOP and Active Satellites

$GPGSV Satellites in view

$GPRMC Recommended Minimum Navigation Information

$GPVTG Track Made Good and Ground Speed
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$GPZDA GPS Time

$PTNL,GGK Trimble RTK positioning data and ellipsoidal height

Configuration

To add the GPS device to the configuration, select "Preferences..." from the options menu and select
the "NMEA0183" tab. 
The following window should now appear:

Select an unused NMEA0183 channel and click the "Setup..." button for that channel. The following
dialog should appear:
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Device Settings

By default, the settings are correct for regular NMEA0183 devices. You only have to select the COMxx
number for the serial port, USB to serial or Bluetooth adapter you are using.
If you didn't connect your serial converter or Bluetooth dongle, you can connect it when this dialog is
open, and click the "Refresh" button to re-detected the available serial ports.

When configuring a RTK receiver, the serial speed can sometimes deviate from the standard. 9600,
19200 and 38400 bps may also be used on these devices.

NMEA0183 Settings

CRC Check

Some devices support a NMEA0183 CRC checksum. If you want to make use of this, enable this option.
When a sentence does not contain a CRC, the CRC check will be skipped, so it is safe to leave this
feature on.

Talker ID

Use this option to filter NMEA0183 sentences by talker ID. It sometimes happens that both echosounder
and GPS devices are transmitting GPS sentences, in this case you can either select the GPS or
echosounder by specifying "GP" or "SD" in this field.

Sentences

To select which NMEA0183 sentences will be decoded, and which ones will be ignored on this channel,
click the "Select sentences..." button.

The dialog that appears allows you to select which sentences are used. For most GPS devices,
selecting only the "$GPGGA" sentence will suffice. If you choose to use the heading and speed
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calculated by the GPS device, you should also select the "$GPVTG" sentence.

Testing the GPS device

When everything has been configured correctly, and the GPS has been turned on and has a valid fix, the
position fields in the "Navigation View" should have green values.
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You can always check whether data is coming in by running the serial communications monitor. 

To start this monitor, select the "Preferences..." option from the "Tools", and selecting the "NMEA0183"
tab. At the bottom of this tab, you will find the "Serial Communications Monitor" section.
Click the "Start..." button to start the monitor, and select one of the NMEA0183 channels to monitor the
input.

2.3.2 Configuring an NMEA0183 compatible echosounder

Introduction

Most echosounders these days do support their own proprietary output format as well as the more
standardized NMEA0183. 
This chapter shows you how to configure an NMEA0183 compatible echosounder with Hydromagic.
If your echosounder does not support the NMEA0183 protocol, you should be able to configure it using
one of the plug-ins shipped with Hydromagic.

In order to connect an echosounder, you need to have at least one available serial port. If there is no port
available, 
you can add a serial port by using an USB-to-Serial converter or a NMEA0183 data combiner equipped
with an USB port. 

When using such a converter, make sure it is connected at the time you are going to configure the
sounder. 

In addition to the serial communications setup, you also have to check the echosounder offset
configuration.

Supported NMEA0183 sentences for sounders

Hydromagic is able to decode the following NMEA0183 sentences used by echosounder devices:

Sentence Description

$SDDBK Depth below keel

$SDDBS Depth below surface

$SDDBT Depth below transducer

$SDDPT Depth and keel offset

Configuration
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To add the echosounder to the configuration, select "Preferences..." from the options menu and select
the "NMEA0183" tab. 
The following window should now appear:

Select an unused NMEA0183 channel and click the "Setup..." button for that channel. The following
dialog should appear:
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Device Settings

By default, the settings are correct for regular NMEA0183 devices. You only have to select the COMxx
number for the serial port, USB to serial or Bluetooth adapter you are using.
If you didn't connect your serial converter or Bluetooth dongle, you can connect it when this dialog is
open, and click the "Refresh" button to re-detected the available serial ports.

When configuring a more sophisticated hydrographic echosounder, the serial speed can sometimes
deviate from the standard. 9600, 19200 and 38400 bps may also be used on these devices.

NMEA0183 Settings

CRC Check

Some devices support a NMEA0183 CRC checksum. If you want to make use of this, enable this option.
When a sentence does not contain a CRC, the CRC check will be skipped, so it is safe to leave this
feature on.

Talker ID

Use this option to filter NMEA0183 sentences by talker ID.
This option is not often used with sounders and should be left empty in most cases.

Sentences

To select which NMEA0183 sentences will be decoded, and which ones will be ignored on this channel,
click the "Select sentences..." button.

The dialog that appears allows you to select which sentences are used. 
For most sounders, selecting only the "$SDDPT" sentence will suffice. 
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Testing the echosounder

When everything has been configured correctly, and the sounder has been turned on, depth field in the
"Navigation View" should display a depth value in green.

You can always check whether data is coming in by running the serial communications monitor. 

To start this monitor, select the "Preferences..." option from the "Tools", and selecting the "NMEA0183"
tab. At the bottom of this tab, you will find the "Serial Communications Monitor" section.
Click the "Start..." button to start the monitor, and select one of the NMEA0183 channels to monitor the
input.
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2.3.3 Configuring hardware using plugins

Using Plugins

By default, Hydromagic can be used with most NMEA0183 devices. To add support for devices not using
the NMEA0183 protocol, plugins are used. Plugins are small programs that are loaded into the memory
when Hydromagic starts. The main advantage of using plugins, is that the main program hasn't to be
replaced each time a new device is used. Instead, a new plugin is installed and loaded by the main
program. Plugins are installed into the "Plugins" folder in the installation directory selected during setup. 

Configuring Plugins

To configure and select the plugins to use, you can open the plugins configuration window by selecting
the "Preferences..." option from the "Tools", and selecting the "Plugins" tab. The following window
should appear: 
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The "Plugin-Manager" automatically detects all available plugins and displays them in the list, along with
their current status (start or stopped). To start using a plugin, select it and click "Configure..." to
configure it. This configuration wizard is different for each plugin.

After configuring the plugin, you can enable it using the "Start" button. To disable it, use the "Stop"
button. The current state of the plugin is stored when exiting the program. When a plugin has been
enabled, it will be started automatically when Hydromagic is started. 

Troubleshooting

When a plugin fails to load for some reason, an error icon is displayed as shown in the screenshot
below: 

To find the cause of the error, you can have a look at the eventlog. The eventlog can be displayed by
selecting the "Show Event Log..." option from the "Help" menu. In most cases, either the plugin cannot
be start because it is missing, or when you selected a device that is already in use or not longer
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present. 

Monitoring Serial Communications

When a plugin has been started successfully, but isn't giving the correct results, you can have a look at
its incoming data using the "Serial Communications Monitor".
To start this monitor, select the "Preferences..." option from the "Tools", and selecting the "NMEA0183"
tab. At the bottom of this tab, you will find the "Serial Communications Monitor" section.
Click the "Start..." button to start the monitor, and select the plugin from the drop-down list as shown
below:

2.4 Geodesy Configuration

2.4.1 Manage Ellipsoids

Introduction
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To open the "Manage Ellipsoids" window, select "Options" => "Coordinate Systems" => "Manage
Ellipsoids..." from the menu. Using this window, you will be able to view, delete or modify existing
ellipsoid definitions, or to add your own. For a list of ellipsoids that are already in the database, click
here. 

Ellipsoid List

When clicking an item in the list, its parameters are displayed below the list. You can edit these
parameters by clicking the "Modify" button.

Deleting an ellipsoid

You can delete an ellipsoid definition, by selecting an item from the list and clicking the button "Delete".
The software will show a popup to confirm that you are sure you want to delete. Please note that you
cannot delete ellipsoids that are used in a datum definition.

Modifying an ellipsoid

You can modify an ellipsoid by clicking the "Modify" button after you selected an ellipsoid from the list.
After clicking the button, the "OK" button text will change to "Save". Clicking the "Save" button will save
the modifications, clicking "Cancel" will keep the old data.

Adding an ellipsoid

http://www.eye4software.com/resources/ellipsoids
http://www.eye4software.com/resources/ellipsoids
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To add a new ellipsoid definition, click the "Add" button. When adding a new definition, it is required to
specify a name for this ellipsoid, otherwise it cannot be saved. Other required fields are "Semi-Major
Axis" and "Inverse Flattening". Click the "Save" button to store the newly created ellipsoid, by clicking
cancel the input is ignored and you will return to the list.

2.4.2 Manage Map Datums

Introduction

To open the "Manage Datums" window, select "Options" => "Coordinate Systems" => "Manage Map
Datums..." from the menu. Using this window, you will be able to view, delete or modify existing datum
definitions, or to add your own. For a list of datums that are already in the database, click here. 

http://www.eye4software.com/resources/datums
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Supported Transformations

In Hydromagic, you need to set the transformation parameters to convert to WGS84 for each newly
created datum. The following transformation methods are supported:

    None (no transformation needed);
    Molodensky (3 parameters);
    Bursa Wolf (7 parameters);
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    NADCON;
    HARN/HPGN;
    NTv2.

Grid Files

The last three methods mentioned above do not require parameters, but you have to specify a valid grid
file. For NADCON and HARN/HPGN, files for North America are shipped with the product. To add your
own NADCON, HARN or NTv2 files, just copy the file to the "NADCON" or "Ntv2" folder in the "Program
Data\Hydromagic" installation directory. 

Datum List

When clicking an item in the list, its parameters are displayed below the list. You can edit these
parameters by clicking the "Modify" button.
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Deleting a datum

You can delete an datum definition, by selecting an item from the list and clicking the button "Delete".
The software will show a popup to confirm that you are sure you want to delete. Please note that you
cannot delete datums that are used in a grid definition.

Modifying a datum

You can modify a datum by clicking the "Modify" button after you selected a datum from the list. After
clicking the button, the "OK" button text will change to "Save". Clicking the "Save" button will save the
modifications, clicking "Cancel" will keep the old data.

Adding a datum

To add a new datum definition, click the "Add" button. When adding a new definition, it is required to
specify a name for this datum, as well as the ellipsoid used. Other fields are optional and are defaulting
to 0.0 when not used.

Please note that the X,Y and Z translations have to be entered in Meters, the X,Y and Z rotations are
entered in arc seconds. If you have a datum definition that uses radians, you have to convert from
radians to arcseconds first: 1 radian = 206 264.806 arcseconds.

Click the "Save" button to store the newly created datum, by clicking cancel the input is ignored and you
will return to the list.

2.4.3 Manage Map Grids

Introduction

To open the "Manage Grids" window, select "Options" => "Coordinate Systems" => "Manage Map
Grids" from the menu. Using this window, you will be able to view, delete or modify existing grids
definitions, or to add your own. For a list of map grids that are already in the database, click here. 

http://www.eye4software.com/resources/grids
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Grid List

When clicking an item in the list, its parameters are displayed below the list. You can edit these
parameters by clicking the "Modify" button. The map grid list can be sorted by clicking on the list
columns. You can sort the list by country, grid name and geodetic datum used. A map grid definition is
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displayed by the flag of the country where it applies to. If a grid can be used in multiple countries /
regions, instead of a flag, a globe is displayed.

Deleting a grid

You can delete an datum definition, by selecting an item from the list and clicking the button "Delete".
The software will show a popup to confirm that you are sure you want to delete. When clicking "Yes" the
grid has been deleted.

Modifying a grid

You can modify a grid by clicking the "Modify" button after you selected a grid from the list. After
clicking the button, the "OK" button text will change to "Save". Clicking the "Save" button will save the
modifications, clicking "Cancel" will keep the old data.

Adding a grid

To add a new grid definition, click the "Add" button. When adding a new definition, it is required to
specify a name for this grid, as well as the datum and projection used. Depending on the chosen
projection, the input fields are enabled or disabled. The table below shows what fields are required for the
different projections: 

Selecting a country is not required, but the country can be used to sort lists by country, if the grid does
not apply to a simple country, just select "Earth", "Europe", "Asia" etc... When you want to use other
units for the Northing and Easting values calculated ( default is Meters ), you can also select the units to
be used. Please note that when changing this, you also have to enter the False Northing and False
Easting in these units. Units currently supported are:
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    Meters
    Kilometers
    International Foot
    British Foot
    Clarke's Foot
    Gold Coast Foot
    Indian Foot
    British Foot (Sears)
    U.S. Survey Foot
    Link
    Clarke's Link
    British Link (Sears)
    U.S. Survey Link
    Statute Mile
    U.S. Survey Mile
    Chain
    Clarke's Chain
    British Chain (Sears)
    U.S. Survey Chain

Click the "Save" button to store the newly created grid, by clicking cancel the input is ignored and you
will return to the list. 

2.4.4 Manage Countries

Introduction

To open the "Manage Countries" window, select "Options" => "Coordinate Systems" => "Manage
Countries..." from the menu. Using this window, you will be able to view, delete or modify existing
country / region definitions, or to add your own. The use of countries / regions is not required to perform
calculations. It is only added to provide a mechanism to sort the map grids by the region or country they
are used for. 
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Country

When clicking an item in the list, its parameters are displayed below the list (country name and flag
filename). You can edit these parameters by clicking the "Modify" button.

Deleting a country

You can delete a country definition, by selecting an item from the list and clicking the button "Delete".
The software will show a popup to confirm that you are sure you want to delete. Please note that you
cannot delete countries that are used in a grid definition.

Modifying a country

You can modify a country by clicking the "Modify" button after you selected a country from the list. You
can for instance translate the country name to your own language, or modify previously created regions.
The flag associated with the country or region can be changed by clicking the "Browse" button. How to
add your own symbols or flags is described in the "Adding a country" section below. After clicking the
button, the "OK" button text will change to "Save". Clicking the "Save" button will save the modifications,
clicking "Cancel" will keep the old data.
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Adding a country

To add a new country definition, click the "Add" button. When adding a new definition, it is required to
specify a name for this country. Specifying a symbol or flag for this country is optional, when no image
has been specified a globe is displayed in the grid list. If you want to add your own symbol, convert this
symbol to a 16x16 PNG Image file and copy this file to the "Flags" folder in the program directory. You
can select a flag or symbol by clicking the "Browse" button. The software ships with flags for most
countries around. Click the "Save" button to store the newly created datum, by clicking cancel the input
is ignored and you will return to the list. 

2.5 Software Configuration

2.5.1 Position Offset

Please note that you have to check for faulty hardware and incorrect geodesy
settings first before using this function !
This setting is not stored inside your soundings, so there is no way to see the
sounding has been altered using a position offset !

Introduction

In some cases, it is required to add a small offset to the received GPS position, for instance, when the
GPS uses a different map datum then WGS84. 
There are 2 ways to set and reset this offset, by using the map or by entering the offset manually.

The offset is used in both the sounding recorder and the map display. 

Calibrate the vessel's position using the map display

Calibrating the GPS position using the map is most probably the easiest method to set a new offset.
From the menu, select "Cursor" => "Set Position Offset". 
Now you can select the correct position using the mouse by clicking the left mouse button. 
Confirm the new position by clicking the "Yes" button in the message windows that appears, and the
vessel will now move to the selected position.

To set a new offset, just repeat the step as described above. To reset this offset, select "Cursor" => "Set
Position Offset" from the menu, and right-click anywhere on the map. 
Confirm by clicking the "Yes" button in the message windows that appears. The vessel is now drawn at
the original GPS position. 
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Manual calibration

To set the position offset by hand, select the "Preferences..." option from the "Options" menu. 
Now select the "Calibration" tab. In the "GPS Offset" section, you can set the X and Y offsets. 
To enable this offset, check the "Use GPS Offset" box.

To clear the offset, just click the "Reset" button. 
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2.5.2 Echosounder Offset

Introduction

The echosounder offset can be used to correct the difference between the depth outputted by the
echosounder, and the real depth.
The transducer of the echosounder measures the waterlevel from the bottom of the transducer to the
bottom of the river.

The height of the water which is above the bottom of the transducer has to be added to the echosounder
output, and can be entered here.
Most echosounders have the option to enter the distance between the water surface and the transducer,
so in this case you do  not have to use this option, or you can use it for other corrections.

Entering the echosounder offset

To enter an offset for the echosounder, select "Preferences..." from the "Option" menu. 
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In the dialog that appears, select the "Calibration" tab. You should see the following dialog:

The value entered is added to the depth reported by the echosounder. To substract from the sounders
value, just prefix the value with the minus sign "-".
To disable the correction, just remove the tick from the "Use Echosounder Offset" checkbox, or click the
"Reset" button to load the defaults.

NMEA0183 compatible echosounders or fishfinders

When using a NMEA0183 compatible echosounder of fishfinder, whether to enter an offset depends on
the NMEA0183 sentence(s) used to retrieve the depth data.

Sentence Depth Value Correction

$SDDBK Depth below keel Enter the distance between the keel of the ship and the water
surface.
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$SDDBS Depth below surface No correction is needed, as the depth is measured from the
water surface.

$SDDBT Depth below
transducer

Enter the distance between the transducer and the water
surface.

$SDDPT Depth The offset configured in the echosounder is used.

2.5.3 Vessel shape and offsets

Introduction

Using the built in "Vessel Editor" you can specify how the vessel should be drawn on the map. It also
allows you to set the exact location of the sensors, like transducer and GPS antenna.
The position of the sensors is used to calculate the offset between the GPS position and the transducer
position when the vessel's heading is known.

The vessel editor

To start the "Vessel Editor" utility, open the preferences dialog by selecting "Preferences..." from the
"Options" menu.
In the preferences dialog, select the "Map" tab, and click the "Editor..." button as shown in the
screenshot below:



Eye4Software Hydromagic34

© 2013 Eye4Software B.V.

The vessel editor will be started and will display the vessel as specified in the "File" field. If no vessel file
has been specified yet, it opens with a blank project.
You will notice two circles labeled "TXD" and "GPS". The "TXD" circle can be dragged onto the ship to
mark the location of the transducer, the "GPS" circle is used to mark the location of the GPS antenna.
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Loading designs

Hydromagic is shipped with a couple of example vessel files. To load one of these files into the vessel
editor, select the "Open Design..." option from the "File" menu.
By default, all vessel designs are stored in the "C:\ProgramData\Hydromagic\Vessel" folder.

Adding and modifying features

To add a line segment or polygon to the design, select "Draw Polyline" from the "Cursor" menu.
To change the location of a single point, you can either drag the point around using the mouse, or alter
the coordinates manually by right clicking the point, and select the "Edit Vertex..." option.

Removing features

Existing segments can be modified by using drag and drop. To remove features from the design, right
click on the shape in the "Object View" windows, and select "Remove Polyline".
To remove a single point (vertex) from a line segment or polygon, right click the point and select the
"Remove Vertex..." option from the context menu.

Grid options
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To change grid options, select "Grid" from the "Options" menu. Using the grid options, you can display a
grid which can be used as guidance when placing objects.
The grid can also be used to snap objects to, both options can be enabled or disabled.

Saving designs

After the design has been completed, and the GPS and transducer locations have been selected, you
can save your design by selecting "Save Design..." from the "File" menu.
Now you can close the "Vessel Editor" and select the design in the Hydromagic Survey software. When
a valid GPS position is available, the ship will be drawn on the map using the specified vessel shape:
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2.5.4 Sound Velocity

Introduction

When surveying deep waters, like oceans, it is not possible to calibrate your echosounder using the bar
check procedure. 
In this case you have to calculate or measure the sound velocity for each layer of water your sounding
signal will pass.

By default, echosounders use a sound velocity of 1500 meters per second. This is only true for fresh
water. 
By using the "Sound Velocity Correction" utility, you can calculate and enter the correct values for
different layers of (ocean) water. 

Starting the "Sound Velocity Correction" utility

The tool can be found in the "Calibration" tab of the "Preferences" screen. 
To show the "Preferences" screen, select "Preferences..." from the "Options" menu, and click the
"Setup..." button in the "Sound Velocity" section of the dialog. 

After starting the tool, the following window should appear: 
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By using either the "Add...", "Remove..." and "Edit..." buttons, you can insert, delete or alter values in
the table. Changes made will be directly visible in the graph display.

When saving your project, changes made in this tools are saved together with the project. It is also
possible to import and export the sound velocity table to a XML file, in order to either use it with a
different project, or to backup your data before altering the table. When clicking either the "Load..." or
"Save..." button, a file selection box, defaulting to the sound velocity data folder, will appear. 

Adding a new correction range

You can insert a new sound velocity value in the table by clicking the "Add..." button. You have to enter
the begin and end depth of the water layer. The sound velocity value can be entered by hand (for
instance when you have a sound velocity probe), or you can calculate a sound velocity value by using
the built-in calculator. 

Calculating sound velocity
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The following sound velocity calculation formulaes are supported: 

Mackenzie;
Coppens;
Wilson;
Medwin I;
Medwin II;
del Grosso;
UNESCO.

To calculate a value for a water layer, click the "Calculate" button, and the following dialog will appear: 

Enter the water temperature and salinity of the water, and enter the depth or pressure, depending on the
formula your are using. Please note that the "del Grosso" and "UNESCO formulaes" take the pressure
at a certain depth as parameter, for all other formulaes, just enter the depth value.

After calculation, click "OK" to select the calculated value, or click "Cancel" to ignore the result. 

Reset corrections

To clear the sound velocity table, just click the "Clear" button. After a confirmation the table will be
cleared. 

Correcting your sounding

When a sounding is created or loaded, the sound velocity table will be applied automatically.
It is also possible to change sound velocity values after the sounding has been made.
To check whether the corrections have been applied to your sounding, just open the sounding editor, and
check the values in the "S/V" column: 
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2.5.5 System Settings

System Settings

The system settings window allows you to adjust some system wide settings, such as date and time
formats and power saving behaviours.
To access the system settings window, first select the "Preferences..." item from the "Options" menu to
open the preferences dialog.

In the preferences dialog, select the "Miscellaneous" tab, and click the "Setup..." button in the "System
Settings" section as shown below:
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The system settings dialog

After clicking the "Setup..." button, the following dialog appears:
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Windows Screensaver

When the "Disable Windows Screensaver activation" option has been selected, Hydromagic prevents
Windows from starting the screensaver as long as the Hydromagic application has focus.
Please note that this option only works when a screensaver without password protection is used. This
options prevents situations where your screen blanks when you do not touch the mouse or keyboard for
some time when performing a survey.

Windows Powersaver

When the "Disable Windows Powersaver activation" option has been selected, Hydromagic prevents
Windows from putting the monitor or laptop display in sleepmode as long as the Hydromagic application
has focus.
This options prevents situations where your screen blanks when you do not touch the mouse or
keyboard for some time when performing a survey.

Time Formats

Use this option to specify the time and date formats used in Hydromagic for log files, exported ASCII
data, screendumps and printing.
Click the "Setup..." button to access these settings.
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To change the time and date formats, select your language and country using the "Language" selection.
After selecting the language, the dialog displays the possible date and time formats for this language.

You can preview the settings in the "Preview" pane. To apply the settings, click "OK".
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3 User Interface Features

3.1 Toolbar

Toolbar

The toolbar contains a selections of the most common used features, so they can be accessed with a
single mouse click. The toolbar can be fully customized, it is for instance, possible to remove buttons
which are never used. This makes the program more user-friendly. 

Button Function

Asks to save the current project, closes it and starts a new one.

Asks to save the current project, closes it and opens an existing project.

Saves the current project.

Sends the map, as displayed on the screen, to the printer.

Import a map, and add it to the current project.

Import soundings, routes or waypoints from a GPS data file.

Import a matrix, and add it to the currect project.

Import a sounding, section or boundary from an ASCII data file.

Import a sounding from a NMEA0183 log file.

Start the map downloading tool to download maps and add them to your project.

Exports a selection of the current project as KML file (Google Earth).

Exports a sounding as an ASCII data file.

Saves the current view as an image file (JPG/GIF/PNG/TIF or BMP).

Adjust the drawing order of maps in the project.

Set cursor mode to "pan", allowing you to drag the map around using the mouse.

Set cursor mode to "info", click an object to show more information (vector maps only).

Set cursor mode to "zoom in", click the map to zoom in.

Set cursor mode to "zoom out", click the map to zoom out.

Set cursor mode to "zoom window", select a rectangle on the map to zoom.

Zoom to extends of active map.

Set cursor mode to "move chart", click the map to pan the map.

Rotate the map 15 degrees counter clockwise (CCW).

Undo rotation (north up).

Rotate the map 15 degrees clockwise (CW).

Rotate the map clockwise (CW) by specifying the rotation in degrees.

Measure area, perimeter, bearing or distance.
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Boundary drawing tool. Starts drawing a boundary on the map. Right click to save.

Shoreline drawing tool. Starts drawing a shoreline on the map. Right click to save.

Draw the map in course up mode. Click again to switch back to north up.

Zoom to current location. Map will be zoomed to vessel's position.

Calibration tool. Click map to set new position offset.

Preferences. Open preferences window.

Start / Stop recording a sounding.

Store current location with annotation flag set.

Quick start a new sounding using the preferences of the last created sounding.

Activate previous cross-section or planned line (used for helmsman display).

Activate next cross-section or planned line (used for helmsman display).

Reset position, sounder or speed alarm(s).

When active, the drag-and-drop feature will be disabled (locked).

Increase tide level.

Decrease tide level.

Set  tide level manually.

Edit matrix color and legend settings.

Show version and licensing information.

Display the offline user manual.

3.2 Accelerator Keys

Accelerator keys

An accelerator key is a key on your keyboard that you can press to quickly access a menu or function.
This can be used for often used functions, such as start or stop recording a sounding.
When using an accelerator key, you do not longer have to use the mouse while trying to navigate your
vessel at the same time.

Default accelerator keys

A couple of accelerator keys are already defined after installation of the software. 
These keys provide direct access to the functions in the "Survey" menu as shown below:
Accelerator keys are supported since Hydromagic version 5.2.
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Adding and modifying accelerator keys

In addition to the standard accelerator keys, there is a possibility to add keys by your own, to modify
accelerators, or to reset all accelerators to their default values.

To do so, click the small arrow at the right of the toolbar, and select the "Customize..." option as show
below:

In the dialog that appear, click the "Keyboard" tab to access the accelerator configuration:
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To create a new accelerator, for instance, the F1 key to access the offline help program, select the
menu item you want to associate with the F1 key as described in the following steps:

For the "Category" drop down box select "Help", and for "Commands" select "User Manual...";
Click the "Press New Shortcut Key" field with your mouse;
Now press the key you want to use, this can also be a combination of keys, for instance, CTRL + F9,
in this case we just press F1;
Click the "Assign" button to select the key;
Finished, you can now click the "Close" button to save your changes.

After performing the steps above, you should see something like this:
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To reset all accelerator keys to their default values, just click the "Reset All" button.

3.3 Data Window

Introduction

The GPS dataview is used to display all information retrieved from a connected GPS to the user. The
dataview is integrated in the Hydromagic environment as a docked window. 
By default, it is displayed on the left from the map display.

The following information can be displayed in this view:

    Current position in WGS84 latitude and longitude;
    Current position in UTM coordinates;
    Current position in the selected local grid;
    Altitude, course and speed;
    (D)GPS fix quality and used satellite(s) count;
    DGPS beacon ID and age;
    PDOP, HDOP and VDOP;
    Calculated position error;
    MSK receiver information;
    Current Time;
    Navigation Info.
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Showing or hiding the view

By default, the dataview is displayed as a docked tabbed window. If you want to show or hide this
window, just select the "Navigation Data" option from the "View" menu. Sometimes the windows is
already displayed, but as a tabbed window. You have to select the "Navigation Data" tab to bring the
window to the foreground. This tabs look like the image below:
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Select items to display

You can easily modify the dataview by showing and hiding items. By showing only the needed
information, the display will become more well organized. To select the items to display, right-click on
the dataview to show the following dialog. You can just select the items to display, by checking them.

Position - Latitude / Longitude

Your current GPS position in WGS84 latitude and longitude format. It is possible to change the display
format used. The display format can be modified from in the "Units" tab in the preferences window
( "Preferences..." from the "Options" menu ).

Position - Universal Transverse Mercator

Your current GPS position in UTM (Universal Transverse Mercator). The UTM zone is automatically
detected using your current position, and will also be displayed. The UTM coordinates are displayed in
northing and easting meters.

Position - User Selected Grid

Your current GPS position displayed in either easting and northing or latitude and longitude, depending
on the local map grid used to display the current map. This projection is the same as the projection
displayed in the statusbar at the bottom of the screen.
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Altitude

Altitude of the GPS antenne. Depending on the GPS, this can be the altitude above sea level, or the
altitude above the geoid. The altitude can be displayed in meters or feet. The current altitude unit setting
can modified from in the "Units" tab in the preferences window ( "Preferences..." from the "Options"
menu ).

Course

Course calculated by the GPS. Also know as course over ground.

Speed

Speed calculated by the GPS. Also known as speed over ground. The speed can be displayed in miles
per hour, meters per second, knots and kilometers per hour. The current altitude unit setting can be
modified from the "Units" tab in the preferences window ( "Preferences..." from the "Options" menu ).

GPS Statistics

This option can be selected to retrieve more information on the GPS fix. This section in the dataview
includes the quality of the GPS fix (no fix, GPS fix, DGPS fix, etc...), the number of satellites used and
some basic information on the DGPS reference station used (not available when using EGNOS/WAAS).

DOP

This option can be selected to enable the DOP (Dillution Of Precision) section in the dataview. It shows
PDOP (overall dillution of precision or position dillution of precision), HDOP (horizontal dillution of
precision) and VDOP (vertical dillution of precision).

EPE

EPE is short for Estimated Position Error. These errors are calculated by some Garmin GPS receivers.
The values will not work when a non Garmin GPS device is connected. Enabling this will display overall,
horizontal and vertical position error in meters.

MSK

When a DGPS beacon is received, you can select this option to display more information on the DGPS
reference station used, like frequency, signal strength and bitrate. In case WAAS/EGNOS is used to
provide a differential position, these values are not availbale.

Clock

Just displays the current PC date and time in GMT (Greenwich Mean Time).

Navigation Info

When the software is used in waypoint-to-waypoint navigation, enabling this option will cause the
dataview to show bearing and distance to waypoint. 
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3.4 Helmsman Display

Helmsman Display

The helmsman display (also known as LR-indicator) in Hydromagic can be used to display the cross
track error (XTE) when navigating on planned survey lines. 
It provides you with information on in which direction to steer to follow the planned lines as accurate as
possible.

Activating the helmsman display

The helmsman display can be activated by selecting "LR Indicator" from the "View" menu. The display
will be displayed. 
The display will now be displayed, however, it won't display any useful information until a valid GPS
position is available and a cross section or planned survey line has been selected.

Activating a survey line

Because the cross track error displayed is calculated from the position of your vessel relative to a line,
you have to tell the software which planned survey line you want to follow.
Please note that in Hydromagic, there is no difference between a planned survey line and a cross
section. Cross sections can be used in volume calculations, cross section displays and as planned
survey lines. 
There are several ways to select a cross section:

Right click on the center of a cross section and select "Activate Section..." from the popup menu;
Select a cross section by selecting the previous or next section using the F11 and F12 function keys;
Right click a cross section in the project explorer and select "Set Active";
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Using the display to steer

When a valid position is available, the difference in heading between the vessel and the line is less then
45 degrees, and a cross section has been selected the helmsman display is indicating the distance
between your vessel and the line, as well as the direction:

The value displayed is the distance to the line in the horizontal units selected in the current map
projection.
When the value is displayed in red, it means you are on the port side (left) of the line, and you have to
steer to the steer to the starboard side (right).
When the value is displayed in green, it means you are on the starboard side (right) of the line, and you
have to steer to the port side (left). 

The line that is used to calculate the calculate the cross track error (the line that is activated) is
highlighted in yellow on the chart display:



User Interface Features 55

© 2013 Eye4Software B.V.

3.5 Area Measurements

Introduction

The Eye4Software GPS Mapping Studio offers a variety of tools to calculate or measure the area covered
by a sounding, map feature or other object. 
The results of area calculations are displayed using one of the following units:

    Acres;
    Hectares;
    Square Meters;
    Square Kilometers;
    Square Yards;
    Square Feet.

Areas are calculated by passing all vertices, or sounding positions, as WGS84 latitude and longitude to
the "Vincenty's Formula", which calculates the distances between the coordinates. 
The calculated vectors are passed to a cross-product formula used to calculate the total area of an
object. 
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Setting area units

Before performing an area calculation, make sure the correct area units have been set, otherwise it can
happen that you have to do the measurement again (or convert it to another unit). To specify the units
used for area calculation, open the "Preferences" dialog, by selecting "Preferences..." from the "Options"
menu. Now click on the "Units and Formats" tab. The following window should now appear:
Use the "Area Units" drop down box to select the correct units, and click the "OK" button to confirm. 

Measuring the area of a map object

Areas of map objects can be calculated by selecting the corner coordinates of the polygon using the
mouse. To get the best (most accurate) results, make sure that the object is zoomed in at the
maximum zoom level while all corners of the polygon remain visible.
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Now select the "Area" cursor tool by selecting "Area" from the "Cursor" menu. All you have to do is
select all the corners of the object, as shown in the screen shot below: 

You will notice a blue line drawn around the object. A dialog box appears on top on the map showing the
current area and perimeter of the map object. When you finished measuring, just click the right mouse
button to dismiss the dialog box, and return to the previous mouse mode. 

Calculating the area of a sounding

When a sounding is loaded or updated, the area is calculated automatically. All you have to do to
retrieve the area of a sounding, is to look up the track in the "Sounding List". To do so, right click the
"Soundings" folder in the "Project Explorer", and select "Manage Soundings..." from the popup menu, as
shown in the screenshot below.

If the "Project Explorer" isn't visible, you can show it by selecting "Project Explorer" from the "View"
menu. 
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A dialog box with a list of all loaded tracks is now displayed. You can find the calculated area in the last
column of the view. 
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3.6 Alarms

Alarms in Hydromagic

In Hydromagic, alarms can be configured to alert you, or stop recording a sounding, when specified
conditions are (not) met.
Alarms can be applied to speed, GPS status and raw depth. 

To setup alarms, first select the "Preferences..." item from the "Options" menu to open the preferences
dialog.
In the preferences window, please select the "Alarms" tab to setup alarms:

GPS Alarms
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To setup alarms on the GPS / RTK equipment, click the "Setup..." button in the "GPS Alarm" section.
To enable alarms for GPS, check the "Enable alarm on invalid and inaccurate GPS positions" option.
You will now be able to configure other options:

Minimum GPS quality value

Use this option to make sure only positions are recorded when the GPS is, for instance, in RTK Fixed or
differential GPS mode.
Possible values include:

No Fix
GPS Fix
DGPS Fix
RTK Float
RTK Fixed

When using tide corrections using RTK, it is recommended to use this option with "RTK Fixed"
selected, so you will be notified when RTK tides are disabled.

Minimum GPS satellite count

This options can be used to use only position fixes with a minimum number of satellites in view to
ensure accuracy.
For a valid 2D fix, at least 3 satellites are required, for a 3D fix, you need at least 4 satellites. It is
recommended to set this value to 6 or higher.

Maximum HDOP value
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Activates alarm when the HDOP (Horizontal Dilution of Precision) value exceeds a defined threshold.
Recommended value is 2.0

Maximum DGPS age

The DGPS age indicates the age of the correction data in seconds. When this value goes up, it often
means that the differential GPS or RTK correction signal is temporary lost.
In most scenario's this value will not exceed the value of 5-6. It is recommended to set this value to 10.

Require DGPS beacon id

This option can be used when a DGPS or RTK correction signal is used. When another beacon is
received then the one that is expected, it may result in inaccurate positions, for instance when a
reference station is at a to great distance.
Set this value to the beacon ID that is displayed directly at a successful setup of your reference station.

Sounder Alarms

To setup alarms on the echosounder equipment, click the "Setup..." button in the "Sounder Alarm"
section.
To enable alarms for sounders, check the "Enable alarm on invalid and out-of-range soundings" option.
You will now be able to configure other options:

Minimum Depth

Sets the minimum depth that is expected to be returned from the sounder. This value is not corrected,
but compared to the raw depth returned.

Maximum Depth

Sets the maximum depth that is expected to be returned from the sounder. This value is not corrected,
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but compared to the raw depth returned.

Speed Alarms

To setup an alarm on the speed of the vessel, click the "Setup..." button in the "Speed Alarm" section.
To enable an alarm for speed, check the "Enable alarm on speed limit" option. You will now be able to
configure other options:

Maximum Speed

The maximum speed of the vessel during survey or dredging operations. Due to latency errors, the
recommended speed for performing surveys is 4 km/h.

Alarm Options

Pause sounding recording

When the "Pause sounding recording" option is enabled, the recording of the current sounding is
suspended when the alarm is activated.
You have to press the record button again to resume recording.

Sound Alarm

When the "Sound alarm" option is enabled, then a sound is played when the alarm is activated.

You can reset the sound by clicking the reset alarm ( ) button in the toolbar.

NOTE: When using sound alarm(s), make sure your sound hardware is enabled and the volume
is turned on.
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4 Map display / Background maps

4.1 Loading Maps

Loading Maps

When starting a new project, it is recommended to load a map of the survey area. The map can be used
as guidance to setup your boundaries, cross sections and route.
Hydromagic supports a large number of both vector and raster map formats including:

S-57 Electronic Nautical Charts
S-63 Electronic Nautical Charts
ESRI Shape Files
ARC/INFO Export Files
ARC/INFO Generate Files
ARC/INFO binary coverage files
ARC/INFO ASCII grid files
Atlas BNA boundary files
BSB nautical maps (version 3)
GeoTIFF files
AutoCad DXF files
Microstation DGN files
PNG,GIF,JPEG and BMP image files
USGS Digital Line Graph files
OpenStreetMap XML files
MapInfo MIF/MID files
MapInfo TAB files
IDRISI vector files
GeoJSON files

Downloading Maps

When you do not have any maps of your survey area, you can download one by entering the map's
boundaries.
How to do this is discussed in more details in the chapter "Downloading Maps".

Importing maps

Maps are imported into the project, this means that the next time you open the project, the map will be
loaded automatically.
To import a map to the project, select "Import Map..." from the "File" => "Import" menu, as shown in the
image below.
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Setting Map Projection

In order to load maps correctly, you have to select the local map projection used in your area.
If you haven't done so, the software will prompt you to do this now. If you already set the projection, you
can skip this step.

Click "Yes" to set a map projection, if you click "No" the operation will be canceled.
The following dialog allows you to show a map projection:
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To find your local projection more easily, select a country first. After selecting the country (or region),
only projections valid for this region will be displayed.
To use a projection that is used in multiple countries, for instance UTM projections, you have to select a
region, like "World", "Europe", "Asia" or "North America".

You can add or modify projections by clicking the "Edit Projections..." button. More info on adding user
defined map projections, please see the "Manage Map Grids" chapter in this manual.
When selected a map projection, click "OK" to continue importing map(s).

Selecting Map Files

After setting a valid projection, a file open dialog is presented. By default all supported map formats are
displayed.
You can select one or more maps and click "OK" to load them into the project.

After loading maps, you will be able to display your vessels position on the map, add waypoint,
comments and photo's and to start soundings.

4.2 Loading IHO S-57 ENC's

Introduction

S-57 is a standard for electronic nautical charts defined by the IHO (International Hydrographic
Organization).
S-57 is used for most official hydrographic maps around. Hydromagic supports both unencrypted and
encrypted (S-63) charts.
It is a vector format which contains features (lines, areas and points) and attributes like depth, symbol,
lights etc.
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Obtaining S-57 maps

S-57 maps are availble online (for free) for the following countries:

United States (Inland and coastal waters);
Austria (Inland);
Belgium (Inland);
Bulgaria (Inland);
Croatia (Inland);
Czech Republic (Inland);
Germany (Inland);
Hungary (Inland);
Netherlands (Inland);
Romania (Inland);
Serbia (Inland);
Slovakia (Inland);
Swiss (Inland).

A more detailed list of sources for S-57 data can be found on our website: http://www.eye4software.com/
hydromagic/gettingencs/.
For other countries, data can only be purchased in S-63 format. For more information on S-63, please
refer to the next chapter.

Loading S-57 maps

S-57 maps can be load into Hydromagic by right clicking "Maps" in the Project View, and selecting the
"Import Map..." option as shown in the image below.
The file extension for both S-57 and S-63 maps is ".000". The software will auto-detect whether the
selected map is encrypted or not.

http://www.eye4software.com/hydromagic/gettingencs/
http://www.eye4software.com/hydromagic/gettingencs/
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4.3 Loading IHO S-63 ENC's

Introduction

IHO S-63 is a standard for encrypting, securing and compressing electronical nautical charts, also
known as ENC's. The standard is using CRC32, SHA1, DSA and Blowfish algorithms to ensure
protected delivery of nautical charts. Most commercial ENC's on the market today are protected using
the S-63 standard.

Each software installation contains an unique hardware id which is encrypted and cannot be read by the
user. Charts purchased for this software will work on this installation of the software only. The hardware
id is encrypted using the OEM and manufacturer id forming the 'Userpermit' which is used to purchase
ENC's. 

Purchasing ENC's

S-63 ENC's can be purchased through your local marine supplies dealer, or online reseller. In order to
purchase ENC's you need the 'Userpermit', and register it with the online chart store or your local
reseller. Because the hardware id is encrypted in the Hydromagic registration code or hardlock, it is only
possible to use S-63 ENC's in registered versions of the software. It is not possible to load these charts
when using a trial version. 

Obtaing the userpermit

To obtain the userpermit for your software installation, select the "S63 ENC Permits..." option from the
"File" menu, as shown in the screenshot below: 
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This will launch the "S63 ENC Permits" dialog, which contains the userpermit, and can be used to
activate purchased ENC's. When you are using a registered version of the software, the dialog should
contain the userpermit which can be used to purchase ENC's. 
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Activation of purchased ENC's

When purchasing ENC's you will receive a "PERMIT.TXT" file from your reseller containing the 'Permits'
for the purchased ENC's. After importing this file, you will be able to load these. To do so, relaunch the
permits dialog by selecting "S63 ENC Permits..." from the "File" menu.

You can now load the "PERMIT.TXT" file, by clicking the "Load Permits..." button, and selecting the
received permit file. You only have to do this once, imported permits will be stored until the software is
reinstalled.

When the file has been imported sucessfuly, you will see something like this: 
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In most cases the reseller can supply you with a "ENC Base CD" containing all the charts for your
region. If not, you can download the charts, depending on your reseller, from Primar or IC-ENC.

When the ENC's and permits are correctly installed, just select "Import Map..." from the "File" menu,
and select the ENC you want to load. When trying to load an enc that has not been purchased, you will
receive error SSE 11 as shown in the table below.

When an error occurs during the import of permits, or when loading an ENC, you will receive one of the
errors described in section 4.4.5. In case of an error, contact your ENC reseller. 

Error Code Meaning

SSE01 Self Signed Key is invalid.

SSE02 Format of Self Signed Key file is incorrect.

SSE03 SA Signed Data Server Certificate is invalid.

SSE04 Format of SA Signed DS Certificate is incorrect.

SSE05 SA Digital Certificate (X509) file is not available. A valid certificate can be obtained from

http://www.primar.org
http://www.ic-enc.org
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Error Code Meaning

the IHO website or your data supplier.

SSE06 The SA Signed Data Server Certificate is invalid. The SA may have issued a new public
key or the ENC may originate from another service. A new SA public key can be obtained
from the IHO website or from your data supplier.

SSE07 SA signed DS Certificate file is not available. A valid certificate can be obtained from the
IHO website or your data supplier.

SSE08 SA Digital Certificate (X509) file incorrect format. A valid certificate can be obtained from
the IHO website or your data supplier.

SSE09 ENC Signature is invalid.

SSE10 Permits not available for this Data Server. Contact your data supplier to obtain the correct
permits.

SSE11 Cell Permit not found. Load the permit file provided by the data supplier.

SSE12 Cell Permit format is incorrect. Contact your data supplier and obtain a new permit file.

SSE13 Cell Permit is invalid (checksum is incorrect) or the Cell Permit is for a different system.
Contact your data supplier and obtain a new or valid permit file.

SSE14 Incorrect system date, check that the computer clock (if accessible) is set correctly or
contact your system supplier. 

SSE15 Subscription service has expired. Please contact your data supplier to renew the
subscription licence.

SSE16 ENC CRC value is incorrect. Contact your data supplier as ENC(s) may be corrupted or
missing data.

SSE17 Userpermit is invalid (checksum is incorrect). Check that the correct hardware device
(dongle) is connected or contact your system supplier to obtain a valid userpermit.

SSE18 HW_ID is incorrect format.

SSE19 Permits are not valid for this system. Contact your data supplier to obtain the correct
permits.

SSE20 Subscription service will expire in less than 30 days. Please contact your data supplier to
renew the subscription licence.

SSE21 Decryption failed no valid cell permit found. Permits may be for another system or new
permits may be required, please contact your supplier to obtain a new licence.

SSE22 SA Digital Certificate (X509) has expired. A new SA public key can be obtained from the
IHO website or from your data supplier.

SSE23 Non sequential update, previous update(s) missing try reloading from the base media. If
the problem persists contact your data supplier.

SSE24 ENC Signature format incorrect, contact your data supplier.

SSE25 The permit has expired. This cell may be out of date and MUST NOT be used for Primary
NAVIGATION.

SSE26 This ENC is not authenticated by the IHO acting as the Scheme Administrator.

SSE27 ENC is not up to date. A New Edition, Re-issue or Update for this cell is missing and
therefore MUST NOT be used for Primary NAVIGATION.
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4.4 Supported Raster Formats

Supported Raster Maps

Raster maps are basically bitmap images. They only contain some image data, and in some cases
(GeoTIFF) some georeferencing information. These maps do not support high zoom levels, because they
are limited by the number of pixels the map is stored in.

You can load a raster map into your project by selecting "File" => "Import" => "Import Map..." from the
menu. 

GeoTIFF Files

GeoTIFF files are based on the TIFF (Tagged Image File Format) standard. This
format allows you to insert all sorts of tags into an image file. GeoTIFF uses this to
store information on calibration info and / or projection information in the file. When
you try to load a map that only contains the calibration info (X,Y boundaries and scale
information), you will be asked to set the projection parameters for the map. 

JPG, GIF, TIF, BMP and PNG Image Files

It is possible to use your own images to project routes, waypoints, tracks and
realtime position on. These images can be downloaded from the web (for instance,
image created with Google Earth or maps exported from OpenStreetMaps.org, or
created by scanning paper maps. To use these images, they have to be calibrated in
order to be used. This can be done by selecting some well known coordinates on the
map, or by entering the boundaries of the map. For more information about calibrating
these maps, see the Calibrating Maps Tutorial. When a file has an associated "World
File" the map is calibrated using this information. 

BSB Nautical Charts

BSB map files are rastercharts designed especially for nautical charts. They are used
by several authorities like NOAA. Nautical maps can often be downloaded for free in
the BSB format. When loading BSB files in GPS Mapping Studio, the map is
displayed directly, because all geo info is included in the map. BSB maps use
Lambert Conformal Conic, Mercator and Polyconic projection. 
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4.5 Supported Vector Formats

Supported Vector Maps

Vectormaps are files that contain objects instead of image data. A typical example of an object can be a
line, point, polyline, polygon and more. Sometimes these objects are also associated with some
userdata or a row in a datatable. Because the vector objects drawn at runtime, there is no limitation on
the zoomlevel like rastermaps.

You can load a rastermap into your project by selecting "File" => "Import" => "Import Map..." from the
menu. 

ESRI shape files

ESRI shapefiles are vector maps often used to exchange data between GIS and CAD
applications. Like DXF files, it contains objects rather then image information. An
ESRI shapefiles consists out of 3 parts, a .shp, .dbf and .idx file. The databse and
index files are ignored by GPS Mapping Studio, it only uses the .shp file which
contains the map objects. The .dbf database file is only used by GIS applications.
Map calibration info is extracted from the shp file. When loading an ESRI shapefile,
you have to set the projection parameters by hand. 

AutoCad DXF files

DXF stands for Drawing eXchange Format, and was developed by AutoDesk and is
used in AutoCad software products. It is a vector format, this means the file contains
objects rather then just image information ( pixels ). AutoCad DXF files are not
designed to store georeferencing information, so after loading a DXF map, you will be
asked to set the projection parameters. 

Microstation DGN files

DGN is a vector format used in Microstation CAD software. The software currently
only supports the ISFF (Integraph Standard File Formats) DGN format. The newer V8
DGN format is not supported yet. In ISFF format, all objects are stored as blocks into
a single file. Each Microstation design file starts with a TCB element, containing
global information on the file, like scale, units and extends. 

OpenStreetMap XML files
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OpenStreetMap is a free, web-based, editable map of the whole world. On this
website, you can find both vector and raster mapdata for almost every place on the
world. The data can be exported to a XML format containing all map objects like
areas, natural, buildings and roads. This data can be loaded into the GPS mapping
software. The mapping software will render the data automatically using the correct
colors, or you can set your own rendering rules. All OpenStreetMap data is using
WGS84 (World Geodetic System 1984) as reference, so there is no need to set
projection parameters when a map has been loaded. 

MapInfo MIF/MID files

MapInfo MIF/MID is a propietary format used by MapInfo and other GIS software
vendors. The format uses a MIF file to store all the features, and a MID file to store
the attribute data. Both files are encoded in plain ASCII. The projection used can be
stored in the header of the file. When this information is missing when loading a
MapInfo map, you will be asked to enter these parameters after loading the map. 

ARC/INFO Export files

Arc/Info Export is a proprietary format, developed by ESRI, used to export GIS data
between GIS applications. The data is encoded as plain ASCII. Values are encoded
in scientific notation with single or double precision. Objects supported are, points,
lines, polylines and labels (text). Projection information can be stored in the file, but
most of the times a .PRJ projection file is used. 

4.6 Downloading Maps

Introduction

In circumstances where an electronic nautical map or CAD drawing of your surveying area is not
available, you can use the map download functionality offered by Hydromagic.
It allows you to use street maps or satellite imagery from Google, Bing or OpenStreetMaps as
background image for your project.

Tiles are downloaded from the provider of choice, merged into a map image and geo-referenced to the
projection you are using in your project.
Therefore you have to select the map projection you are going to use before downloading any maps.

Please note that storing map tiles locally breaks the terms of service for a couple
of popular data providers like Google, Bing, and ArcGIS Online.
Use this function at your own risk !

Download Map Tool
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To start the map downloading tool, right click the "Maps" folder in the "Project View" and select the
"Download Map..." option from the popup menu as shown in the image below.
In case you didn't select a map projection for the project yet, you will be asked to do so, if not the
download tool is displayed.

The tool allows you to download street maps or satellite imagery from the following 3 providers:

OpenStreetMaps;
Google;
Bing (Virtual Earth).

Setting area and options

In order to download maps, you have to select the area you need a map for, and which provider you want
to use.
Use the "Information Source" selection box to select the provider and the type of map (streets or
satellite).

The next step is to select the area. Select the smallest area as possible, because the smaller the area,
the higher the zoom level and level of detail.
You have to enter the upper-left and lower-right WGS84 coordinates of the area you are surveying in. 
Because the maps are downloaded as 256 x 256 pixel tiles, it is likely that the actually downloaded area
is a bit larger then the requested area.
You can obtain the coordinates by using a map viewer like Google Earth or others.

Finally, select the name of the output file (the file where the map is stored) and whether to add the map
to the project directly.
Depending on the type of map you are using, the image is stored as PNG (streetmap) or JPG(satellite)
file.
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.

Area selection tools

As an alternative to enter the coordinates manually, you can calculate boundaries from a waypoint,
sounding, boundary, current location or an address.
To do so click the "Calculate..." button. The following dialog will appear:
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The first three options (GPS Position, Address and Waypoint) can be used to specify the center of the
map. To calculate the map extends, you have to enter the map dimensions.
When using the last two options (sounding or boundary), the map dimensions entries are disabled, and
the boundaries are copied directly from the area covered by the selected sounding or boundary.

Please not that when using the "Find Address..." tool, make sure you are connected to the internet in
order to perform a Geo-Coding lookup.

Download

To start downloading, just click the "OK" button. Please note that you have to be connected to the
internet at this moment. 
The download progress is shown in the status bar. First, the tiles are downloaded and merged into a
larger images, which is geo-referenced using the projection set.
When downloading has been completed, and the "Add generated map" options has been checked, the
map will be added to the project and displayed.

4.7 Changing drawing order

Changing map drawing order
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In cases where a map (partially) covers another map, you can control the sequence in which the maps
are drawn.
When using multiple maps, always draw vector maps on top of raster maps (unless the raster maps
have transparency).
You can also use this option to place vector maps on top of a matrix created by Hydromagic

Map Order Tool

To change the map order, select "Layers..." from the view menu. The "Map Display Order" dialog
appears:

Click the "Move To Front" or "Move To Back" buttons to change the drawing order.
Changes will be applied directly. To accept the order, click "OK" to close the tool.

4.8 Adding waypoints to the map

Introduction

A waypoint can be defined as a marked position on a map, somewhere on the earth, with known
coordinates. A waypoint can be part of a route. In GPS receivers, a waypoint is a point that can be
selected as a coordinate to navigate to, or it can be used to just display a symbol on a map. 

Creating a waypoint

In Hydromagic, there are multiple ways to create waypoint. You can create one manually from the
waypoint list, click on the map or create by applying a projection from a known waypoint or GPS
position. The easiest way is by clicking on the map. We will demonstrate in a few steps how to do this.

Zoom and pan over the map until you find the position you want to place a waypoint. Click the right
mouse button, when pointing the mouse to the position, and select the "Add Waypoint" option. The "Add
Waypoint" window will appear. 
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You will notice that the position of the waypoint is already filled. In this window, you can set some
additional information about the waypoint, like the comment, the name, the symbol to be used on the
map etc. The proximity waypoint option will be discussed in a later tutorial, it is mainly used to alert you
if you are within a specific distance from the waypoint. 

Waypoint Properties Window

Name

Use this field to set the waypoint name. When creating waypoints, the software will auto generate the
waypoint name in the range "WPT001" ... "WPT999". You can choose your own name, but please note,
that in case you want to upload the waypoint to your GPS receiver, you have to keep the maximum
waypoint name length of your GPS receiver in mind. The name must be unique: you can not create more
then one waypoint with the same name.

Latitude and Longitude position

These positions are prefilled when you create the waypoint from the map. If you are creating the
waypoint from the waypoint list, the current position is used. You can change these fields to display the
Northing and Easting position using the currently selecting map grid, by checking the "Show position in
Northing / Easting coordinates" check box.
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Symbol

The software contains over 160 different symbols that can be used to display your waypoint on the map.
When uploading the waypoint to your GPS, the same symbol is used, so you must be sure that the
symbol you choose is also present in the GPS device. The default waypoint symbol is the "Black
Rectangle" that is supported by any GPS receiver.

Description

You can add a description for the waypoint here. When uploading the waypoint to the GPS receiver,
depending on the model you are using, the description will be displayed truncated on your GPS receiver.

Waypoint Label

Using the "BgColor", "FgColor" and "Transparent" options, you can modify the colors of the waypoint
label on the map. When transparent is selected, the background color is ignored, and only the text is
displayed on the map.

Proximity Waypoint

If you want to act this waypoint as a proximity point, enable this function. Please note that not all
receivers support this option. When enabled, your GPS will alarm you if you are withing a certain range
from the waypoint. 

Saving the Waypoint

After modifying the waypoint properties, click "OK". When using the settings from the screenshot above,
the waypoint will look like this: 

Modifying or moving the Waypoint

To modify the Waypoint after you placed it on the map, you can use either the waypoint list, or right
click on the waypoint, and select "Waypoint Properties", as displayed below: 
To move the waypoint, click on it and just drag it around on the map. When you release the mouse
button, it's new position is saved. 



Map display / Background maps 83

© 2013 Eye4Software B.V.

The Waypoint List

To view a list off all Waypoints, you can open the Waypoint list, by selecting "View" => "Waypoints"
from the menu. 
From this list, you can remove, add, modify, export and zoom to Waypoints. 
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4.9 Projecting Waypoints

Projecting a waypoint

When projecting a Waypoint, you basically create a Waypoint on a certain distance and heading from a
known position. In Hydromagic, there are multiple ways to project a waypoint. You can project the
waypoint from another Waypoint, a position on the map, a manually entered position or the current GPS
position. In this tutorial, we will project a Waypoint, using another Waypoint as a reference.

To open the "Project Waypoint" window, select the "Tools" => "Project Waypoint" option from the menu.
The following window will appear: 
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 In this window, you will find 2 buttons, a "Select..." button, to select the source Waypoint, and a "GPS"
button which can be used to automatically enter the current GPS position as source location. For this
example, we will use another waypoint, so we click the "Select..." button and choose a Waypoint from
the list. If there is no Waypoint in the list, you can walk through the Creating Waypoints tutorial to create
a one. Once you selected a Waypoint, the coordinates of this Waypoint are copied into the Latitude /
Longitude fields.

For this example, we will create a new Waypoint at 100 meters and a 45 degrees course from the
selected Waypoint. After we entered these values, we click "Project...". 

Saving the waypoint

A "Waypoint Properties" window will appear with the location of the projected Waypoint already entered.
You can now modify the waypoint's attributes such as name and symbol. Please note, that when a new
Waypoint is created, by default the symbol and label properties are copied from the last created
waypoint. This might be very handy when creating multiple waypoints that should use the same
attributes. When done, click "OK" to save the waypoint. 
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Ready !

When looking at the map, you will find the "WPT002" waypoint projected at an angle of 45 degrees and
a distance of 100 meter from the selected waypoint. 
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4.10 Adding comments to the map

Introduction

In Hydromagic, it is possible to add comments or labels to your maps. You can use comments or labels
to, for instance, mark places, or to add extra comments about the map before printing it. You can place
comments using any color or Windows font, with or without background.

Adding a comment

T are multiple ways to add a comment. You can create one manually from the comment list, or click on
the map to place a comment at the current mouse position. The easiest way is by clicking on the map.
We will demonstrate in a few steps how to do this.

Zoom and pan over the map until you find the position you want to place a comment. Click the right
mouse button, when pointing the mouse to the position, and select the "Add Comment..." option. The
"Add Comment" window will appear. 

You will notice that the position of the comment is already filled out. In this window, you can add a
comment to store with the map. You can also change the fore- and background colors and the font used
to draw the comment on the map.



Eye4Software Hydromagic88

© 2013 Eye4Software B.V.

Comment Properties Window

Latitude and Longitude position

These positions are prefilled when you create the comment by right clicking on the map. If you are
creating the comment from the comment list, the current position is used. You can change these fields
to display the Northing and Easting position using the currently selected local grid (if set), by checking
the "Show position in Northing / Easting coordinates" check box.

Comment

Enter the comment here. It will be appear on the map exactly as you entered it in the "Add Comment"
dialog.

FgColor

The color used to draw the text and border. If the transparent option has been selected, no border is
drawn.

BgColor

The color used to draw the text backgound. When the transparent option has been selected, this values
is ignored.

Font

Use this drop down box to select the font for the comment. All installed Windows fonts are displayed.
Please note that when the project is transfered to another PC, which does not have this font installed,
another font is used.

Size

Use this drop down box to select a font size. You can see the result in the preview pane at the bottom of
the dialog.

Saving the comment

After modifying the comment properties, click "OK" to add the comment to the project. When using the
settings from the screenshot above, the comment will be displayed on the map like this: 
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.

Modifying or moving the comment

To modify the comment after you placed it on the map, you can use either the comment list, or right
click on the comment, and select "Edit Comment...", as displayed below: 
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To move the comment, click on it and just drag it around on the map. When you release the mouse
button, it's new position is saved. This option will only work, when drag-and-drop is enabled (look for the
"lock" button in the toolbar). 

The Comment List

To view a list off all comments on the map, you can open the comment list, by right clicking on the
"Comments" folder in the "Project Explorer" and selecting "Manage Comments...". From this list, you
can remove, add, modify, export and zoom to comments. If the "Project Explorer" isn't visible, you can
show it by selecting "Project Explorer" from the "View" menu. 
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4.11 Adding photos to the map

Introduction

In the Hydromagic, it is possible to add references to image files, like photo's on your maps. The
image's will be showed on the map as a camera icons. When clicked, the photo will appear. Possible
application examples include:

    Store images of buildings in your GIS datasets;
    Store underwater photo's or sidescan sonar images in your nautical maps;
    Store images of terrain features in your topographic maps;

Adding a photo

In Hydromagic, there are multiple ways to add a photo. You can create one manually from the photo list,
or click on the map to store a photo on the current mouse position. The easiest way is by clicking on
the map. We will demonstrate in a few steps how to do this.

Zoom and pan over the map until you find the position you want to place a photo. Click the right mouse
button, when pointing the mouse to the position, and select the "Add Photo..." option. The "Add Photo"
window will appear. 
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You will notice that the position of the photo is already filled. In this window, you can add a name and
comment to store with the photo. Also, you have to select an image file by clicking the "Browse..."
button. At this moment, JPEG, GIF, BMP, TIF and PNG files are supported. 

Please note that only the path to the image is stored in the project file. In case of a backup, you have to
backup the image files manually. Once the images are moved or deleted, the images can no longer be
viewed from the map.

Photo Properties Window

Name

Use this field to set an unique name for your photo. This name is also displayed on the map below the
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camera icon and in the project view. It is not possible to create more then one photo with the same
name.

Latitude and Longitude position

These positions are prefilled when you create the photo by right clicking on the map. If you are creating
the photo from the photo list, the current position is used. You can change these fields to display the
Northing and Easting position using the currently selected local grid (if set), by checking the "Show
position in Northing / Easting coordinates" check box. To find the position using geo-referencing, click
the "Find Address..." button. You need to have an active internet connection to use this feature.

Description

You can add a description for the photo here. This field is optional and can be kept empty.

File

Displays the full path to the image file. Click the "Browse..." button to select (another) file, or click the
"Show..." button to view the photo in the "Windows Photo Viewer" application.

Saving the photo

After modifying the photo properties, click "OK". When using the settings from the screenshot above,
the photo will be displayed on the map like this: 

Modifying or moving the photo

To modify the photo after you placed it on the map, you can use either the photo list, or right click on the
waypoint, and select "Edit Photo...", as displayed below: 
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To move the photo, click on it and just drag it around on the map. When you release the mouse button,
it's new position is saved. This option will only work, when drag-and-drop is enabled (look for the "lock"
button in the toolbar). 

The Photo List

To view a list off all photo's on the map, you can open the photo list, by right clicking on the "Photos"
folder in the "Project Explorer" and selecting "Manage Photos...". From this list, you can remove, add,
modify, export and zoom to photos. If the "Project Explorer" isn't visible, you can show it by selecting
"Project Explorer" from the "View" menu. 
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4.12 Creating Boundaries

Boundaries

A boundary is required when using volume calculations. It is also used to specify for which area we want
to create a matrix or contours, or to specify a clipping region for certain graphical operations. 
The easiest way to create a boundary is by drawing a polygon on the map, but it is also possible to
enter the coordinates by hand.

Create by using the mouse

To start a new boundary, just click "Boundary Drawing Tool" button in the toolbar: (  ).

Secondly, use the mouse to select the corners of the area by left-clicking the on corner locations in the
map. When finished, click the right mouse button to store the boundary. The new created boundary
should now appear in the "Project Explorer". By default a new boundary is named "BOUNDARYXXXX"
where "XXXX" is the number of the boundary. Boundaries are drawn as red, dotted lines. The boundary
points are drawn as red rectangles. 
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Modify by using the mouse

To modify a created boundary, regardless whether it has been created by entering coordinates or by
using the mouse, can be modified by dragging it's corner point around. First, you have to activate the
boundary you want to alter. This can be done by right-clicking on the boundary name in the "Project
Explorer", and selecting the "Set Active" option. It is only possible to drag the points around when the
"Disable Drag and Drop" options is turned off (enabled by default). This can be done from the "Cursor"
menu. 

Create by entering coordinates

When your client has supplied a list of coordinates for the area you have to survey, you can also create
a boundary by manually entering these points. To do so, right-click the "Boundaries" folder in the
"Project Explorer" and select the "Add Boundary..." option. The following dialog will appear: 
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The table shows the coordinates of the corners of the boundary. The toolbar at the bottom of the dialog
allows you to insert, delete or alter the coordinates.
This dialog can also be used to modify boundaries created by using the mouse, or to rename a
previously created boundary: 

Button Function

Edit the selected coordinate.

Add a new coordinate to the list.

Insert a new coordinate before the selected coordinate.

Deletes the selected coordinate(s).

Clears the list (delete all coordinates).

Reload the list.

Show selected coordinate on the map.

Toggle coordinates between WGS84 and local grid.

Removing a boundary

A boundary can be removed by right-clicking on the boundary name in the "Project Explorer" and by
selecting the "Remove Boundary..." option. After a confirmation, the boundary will be removed from the
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project. 

4.13 Cross Sections

Cross Sections

In Hydromagic, cross sections are used to create a theoretical 3D design of the area you want to use to
perform volume calculations. The sections are in fact lines from shore to shore containing depth or
elevation information relative to the distance from the shores or riverbanks.

By using a boundary, it is possible to auto generate cross sections from bank to bank (automatic
placement). It is also possible to place them by dragging the sections at the correct place by using the
mouse (manual placement). 

Automatic placement

Using automatic placement, cross sections will be generated to fill a specified boundary. The direction
of, and the distance between the sections can be selected. To use automatic placement, select the
"Generate Sections" option, by right clicking the "Sections" folder in the "Project Explorer". The following
dialog will appear: 

For the "Line Direction" you will normally specify the heading perpendicular to the shore or riverbank.
You can measure the direction of the shore using the built in "Distance and Bearing" tool.

The "Line Distance" depends on the size of the area, in this example we leave it to the default value,
10.0 meters.

Use the section name prefix when you have multiple sets of sections. The software will start the names
of the generated sections with this prefix, so it is more easy to determine to which set a section
belongs. In this example, we will use "DK" as prefix for the section names.

Finally, select the area you want to use as clipping area for the sections. To start generating cross
sections, fill in the required fields and click "OK". The cross sections are now calculated and displayed
on the map: 
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Manual placement

In some cases, the automatic placement will not suffice, for instance for irregular areas or at places the
river makes a turn. You can then make use of manual placement (eventually in combination with
automatic placement).
To create a new section, right click the position of the new cross section, and the following dialog will
appear: 
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Enter a name for the newly created section and click "OK" (we will discuss the other options of this
dialog in the next chapter). A new section will be created with a default length and azimuth. You can use
the mouse to rotate, resize and move the section in the right place.

Moving, resizing and rotating cross sections

After automatic or manual placement, you will notice that a single cross section is drawn as a dashed
purple line with 3 anchor points. You can select these points with the mouse to move or rotate the cross
section using the map.

By dragging the center point of the cross section, you can drag and drop it to the new position. In order
to rotate or resize it, use either one of the start and end points of the cross section.

Please note, that in order to drag and drop any objects on the map, you have to disable the "Disable
drag and drop" option from the "Cursor" menu. 
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Delete cross sections

There are two ways to delete a single cross section:

1. Right-click the center anchor point of the cross section in the map, and select "Remove Section" from
the popup menu;

2. Right-click the cross section name in the "Project Explorer" and select "Remove Section.

To delete all cross sections, right click the "Sections" folder in the "Project Explorer" and select
"Remove All...". After confirmation, all cross sections will be removed from the project. 

4.14 Cross Sections from CAD

Cross Sections from CAD

Instead of placing cross sections by hand, it is also possible to import them directly from an AutoCad
DXF project.
To use this method, please make sure you use a separate AutoCad layer for these lines.

Import

To start importing the line data used to create sections, select the "Generate sections from DXF..."
option by right clicking the "Sections" folder in the project view.
If the project view is not visible, you can show it by selecting "Project Explorer" from the "View" menu.
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File

First, you have to click the "Browse..." button to select a CAD file. At this moment, only AutoCad DXF
files are supported.
If your AutoCad file is in DWG format, you can export it to DXF by using the DXFOUT command in
AutoCad.

When a valid file has been selected, the layer names will be loaded and displayed in the dialog.
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Select Layers

After the file has been loaded, you have to check the layer(s) containing the line data used to generated
sections.
You can select one or more layers, please note that only LINE and POLYLINE entities will be converted.
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Original DXF file, layer to be imported is colored blue

Options

It is possible to change the prefix of the section names, as well as a clipping area. When a clipping area
(boundary) is selected, all lines will be clipped within this area.
When clipping area is set to "N/A" all lines will be loaded  "AS IS".

Starting Import

To start creating lines, just click "OK". After a few seconds you will see the imported lines in your
project.
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Sections generated from DXF file shown above

4.15 Channel Design

Channel Design

After placing cross sections, as discussed in the previous chapter (Cross Sections), we need to set the
depth or elevation information of a couple of coordinates along the cross section. 
These values are stored as pairs of distance and level data, where distance is the distance measured
from the start of the line. 
In order to create a theoretical DTM to be used in volume calculations, we need these values.

When the depth and the slope of the shore are known, it is possible to calculate depths on the cross
sections automatically.

Calculating profiles

To alter a cross section's profile, just right click on the center anchor point, and select "Edit Section...".
The following dialog ("Edit Cross Section") should now appear: 
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When first editing a cross section, you will notice the graph display is empty, this is because no depths
are stored by default. In this example, we will create a channel with a depth of 5 meters and a slope of
50 percent. This means, that for each 2 meters, the bottom depth increases with 1 meter. When the
bottom depth increases with 1 meter for each 4 meter extra distance from the shore, the slope is 25%.
To calculate profiles from this setting, click the "Auto..." button. The following dialog should now appear: 
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In the left section of the dialog, you can enter the channel design parameters, in the right section, you
can select the cross sections you want to apply these parameters to. In this example, the depth at the
shoreline should be half a meter, at the waterway axis, the depth should be 5 meters. The slope used is
50 percent. Click the "OK" button to apply these settings. The graph display will now look like this: 

You can check the other sections by browsing through them using the next and previous buttons. 

Manual editing

In cases where calculation is not usable, for instance when a different slope is used on either sides, or
when a section is not placed between shores, you have to enter the distance and depth values
manually. 

To do so, click the "Edit..." button to open the profile editor: 
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The table at the left of the dialog allows you to alter, insert and delete the distance-depth pairs if the
profile. Changes made, are directly visible in the graphical display. When done, just click "OK" 

Checking the profiles

The quickest way of checking whether al profiles have been created correctly, is by creating a matrix
view using the cross sections. To do so, select the "Generate Matrix..." option from the "Sections" folder
in the "Project Explorer". 
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Select the correct boundary (in most cases the boundary used for auto placement of the sections), a
filename for the matrix, and the spacing used (can be larger for a test, for volume calculation, use the
same spacing as the matrix created from the sounding). Click "OK" and check the result. 



Eye4Software Hydromagic110

© 2013 Eye4Software B.V.



Singlebeam
Soundings

Part

V



Eye4Software Hydromagic112

© 2013 Eye4Software B.V.

5 Singlebeam Soundings

5.1 Creating a new singlebeam sounding

Creating Soundings

Before you can create a new sounding it is recommended to perform the following checklist:

    Make sure the position is valid, and the GPS has good reception;
    Check whether a depth is indicated in the "Data View";
    Check the PC's time and date, this is important when using tide correction.

The next step is to load a background map, this is not required, but it can be used to check whether
your position is still correct, and the software is still writing new soundings to the sounding.

When everything is working okay, the next step is to create a new sounding. A sounding is basically a
list containing the current time, position and depths recorded during the survey. The data collected in
this sounding can be exported or processed when the survey has been finished. 

Creating a new sounding

A sounding can be created in many ways, but the most easiest is to right-click on the "Soundings"
folder in the "Project Explorer" and select the "New Sounding..." option. If the "Project Explorer" is not
visible, you can show it by selecting the "Project Explorer" option from the "View" menu. 

After creating a new souding, the "Sounding Properties" dialog will be displayed. It allows you to alter
the name of the sounding, and how the sounding is displayed on the map. 
You can for instance select a different color for every track, or display only the fixes, or depth/altitude
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value instead of drawing the complete track.

You can modify the sounding's properties at any time by right clicking the sounding in the "Project
Explorer" and selecting "Edit Sounding...". 

Start Recording

When a sounding is loaded and selected, the active sounding name (the name of the sounding new fixes
will be appended to) is displayed in the right corner of the status bar. 

You will also notify that the "Record" button ( )in the toolbar is enabled. You can click this button to
start and stop adding soundings to the selected track.

Before starting recording a sounding, it is required that the current project has been assigned a valid
name. If you haven't done so, you will be notified.
Without a valid projection name set, the autosave function won't work. You can set the project name by
using the "Save As..." function from the "File" menu.

By default, when creating a new sounding, it is set as the active (or selected) sounding. 
To select a different sounding to append positions to, select the desired sounding in the "Project
Explorer", right click on it, and select "Set Active". 
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Autosave option

To prevent data loss, for instance due to a PC crash or AC power failure, it is recommended to use the
"AutoSave" option. 
When this option is enabled all project data (including sounding) will be saved at the specified interval.

To change the autosave option, select "Preferences..." from the "Options" menu, and click the
"Miscellaneous" tab. You will see an "Auto save" section at the bottom of this window. Now click the
"Setup..." button in this section. Enable the check box when you want to use autosave, and enter an
interval (minimum 1 minute). Click the "OK" button to apply the changes.

Manually saving the sounding

A sounding can be saved by just clicking the "Save" button in the toolbar ( ). It will be saved inside the
project file. It is also possible to export it to another file format for use in other applications.
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For more information, please refer to the "Exporting Soundings" section of this manual.

5.2 RTK Tides

RTK Tides

Using a RTK receiver in fixed mode, you have X, Y and Z coordinates with an high accuracy ( < 2 cm ).
Using the Z coordinate (also known as ellipsoidal height), you can calculate the current tide level in real-
time, making it no longer necessary to have a tide gauge connected to the software, or to correct the
sounding afterwards.

Requirements

In order to calculate tide levels in real-time, you need a RTK receiver with a valid correction signal.
This correction signal can be provided by a GSM / GPRS ( NTRIP ) service provider, UHF base station or
your own base station on a known location.

You also need a local geoid model. This is a file containing geoid - ellipsoid separation values for the
area or country you are performing your survey.

Hydromagic ships with a couple of geoid models, including Belgium, the Netherlands and North
America. If no geoid model is available for your area, please contact support.

To perform the calculation, you also need to know the exact distance between the receiving element of
your RTK antenna and the water surface.

Receiver Output

To retrieve the ellipsoidal height from your RTK receiver, it should have an NMEA0183 data output,
supporting either the $GPGGA or $PTNL,GGK sentence as shown in the examples below:

 $PTNL,GGK,453049.0,0,3728.455440850,N,12215.253291068,W,3,9,2.0,EHT35.7424,M*

Trimble proprietary message for RTK position

 $GPGGA,042629.00,3242.86076286,S,15133.15384408,E,4,12,1.1,6.573,M,26.799,M,1.0,0000*51

Standard NMEA0183 sentence for GPS or RTK fix data

When the Trimble proprietary NMEA0183 message is used, the ellipsoidal height is provided directly in
the sentence, in the example above it is in the ellipsoidal height (10) "EHT35.7424" field.

For standard NMEA0183, the ellipsoidal height is calculated from the M.S.L. (9) height and geoidal
separation (11) field. In this case the ellipsoidal height is calculated by using the formula below:
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In the example above, the ellipsoidal height is 6.573 + 26.799 = 33.372 meter.

 Ellipsoidal Height = M.S.L. Height + Geoidal Separation

Formula for calculating ellipsoidal height from NMEA0183 GGA sentence

Please not that the M.S.L. ( Mean Sea Level ) height value returned by the GPS is calculated using the
global EGM96 geoid model, and isn't accurate enough to use for your surveys.
This is why you have to provide a local geoid model instead.

RTK Configuration

In order to configure Hydromagic to use RTK tides, open the preferences dialog by selecting
"Preferences..." from the "Options" menu.

To view the RTK configuration, click the "RTK" tab. You should see following dialog:
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To enable tide calculation, you have to check the "Use Real Time Kinematic (RTK) for real time tide
calculation" box. When checked, you can alter the other configuration options.

First you have to enter the height of the antenna above the water surface. Make sure to measure this
distance as accurate as possible, an error in this measurement is directly converted to an error in the
tide level. Secondly, select the geoid model used in your area by clicking the "Select..." button.
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For some area's it is possible to select a vertical reference, like NAVD88, NVGD29, M.S.L. etc.
Please note that this setting is ignored for some countries.

When finished configuring, just click "OK" to apply the settings.

Testing RTK and geoid calculations

In order to test RTK tide calculations, connect and power on your RTK receiver and make sure you have
a valid RTK fix.

The next step is to check the values in the "Navigation Data" window. If this view isn't visible, you can
activate it by selecting "Navigation Data" from the "View" menu.
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You have to check the following:

The EHT (Ellipsoidal Height) is displayed in the data view. If missing, check the NMEA0183
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configuration of your RTK receiver.
When using the Trimble proprietary NMEA0183 sentence, the M.S.L. field can be 0.00.
You should have RTK Fix in the GPS Information section.
The RTK tide value is displayed in green.

Start sounding

When the conditions above match, you can just start a new sounding and proceed with your survey.
When exporting the sounding both the ellipsoidal height and RTK tide level can be exported as a text
file, along with the X,Y and Z coordinates.

5.3 Exporting soundings

Introduction

Using the ASCII export function, it is possible to export tracks in ASCII format for use in other
applications. It is also useful to backup separate track files from a project, for instance to import them
into another project or just for archiving. The ASCII import function allows you to import soundings written
in ASCII format. For instance, to import a sounding exported from another Hydromagic project, or
created with other software. 

Exporting sounding data

The ASCII export function allows you to export your soundings in ASCII format. You can use this feature
to create backups of your work, or when you want to use the data in other applications.
To start, open the "Export ASCII" dialog by selecting "File" => "Export" => "Export ASCII Data..." from
the main menu. The following dialog will appear: 
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Select output file

Click the "Browse..." button to select the destination folder and filename for the data to export. First
select the folder you wish to store the file into, and secondly, type the name of the file. Recommended
extensions for ASCII files include: *.ASC, *.TXT, *.LOG and *.CSV.

Select data to save 

Using the "Data To Save: selection box, you can select which data you want to export to an ASCII file. It
is possible to export soundings, matrices, lines and boundaries. In this example we want to export a
sounding, so we select the desired sounding from this box.

Select format options and field order

The output format is fully customizable, the following fields can be selected for export:

   Longitude;
    Latitude;
   Easting;
    Northing;

Depth;
Ellipsoidal height;
Date;
Tide;
Time;
Draft;
Heading;
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Speed;
Sound velocity correction.

To customize the exported fields, and the field order, click the "Select..." button. The following dialog will
be shown allowing you to select the fields.
Click "OK" to confirm and return to the "Export ASCII" dialog.

Select map projection and units

It is possible to store the file using another local grid then the one you are currently using in your project.
To change the output grid, click the "Select..." button and select the desired map grid or map datum. In
this section you can also specify in which units the depth should be written to the ASCII file.

Starting the export

Just click "OK" to start writing the file. When all parameters were entered correctly, the exported file
should appear in the folder you selected.

5.4 Importing Soundings

Introduction

The ASCII import function allows you to import soundings written in ASCII format. For instance, to import
a sounding exported from another Hydromagic project, or created with other software. 

Importing sounding data

The ASCII import function allows you to import soundings written in ASCII format. For instance, to import
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a sounding exported from another Hydromagic project, or created with other software.
Open the "Import ASCII Data" dialog

The dialog can be opened by selecting "File"=>"Import"=>"Import ASCII Data..." from the main menu.
The following dialog will appear:

Select input file

Click the "Browse..." button to select the file to be imported. All files will be displayed, there is no file
extension filter applied. Some file extensions that are commonly used for ASCII files include: *.ASC,
*.TXT, *.LOG and *.CSV. The imported file is never modified by this software. This dialog can also be
used to import boundaries, grids and waypoints. Make sure the "Load data as" options is set to
"Sounding".

Field Separator

This value is set to "Auto" by default, which means that the software will try to detect which character is
used to separate the fields in the ASCII file.
In most cases you do not have to adjust this value.

Skipping lines and fields



Eye4Software Hydromagic124

© 2013 Eye4Software B.V.

In cases where the data does not start on the first line of the file (for instance, when header names are
present), you can skip these lines by increasing the "Number of lines to skip value".
The "Number of fields to skip option" can be used in cases where there are fields before the actual XYZ
data, for instance, record Id's.
You can use the "View" button to check if these options apply to your input file.

Coordinate field order

This option is to set the order of the fields in the file. The following is supported:

    Latitude, Longitude;
    Longitude, Latitude;
    Northing, Easting;
    Easting, Northing;

When a third field is present in the file, it will be interpreted as depth. 
Most software stores soundings in XYZ format, so selecting "Easting, Northing" here would probably
work in most cases.

Coordinate field format

When the input files contains values in geographic format (i.e. latitude and longitude), and the
coordinates are stored in degrees, minutes and seconds format, or degrees and minutes format, set this
option to the correct value.
When coordinates are stored in decimal values, leave the "Decimal" option selected.

Projection and Units

The software needs to now which projection is used in the file (only when Northing and Easting
coordinates are used instead of Latitude and Longitude), so it can be referenced to WGS84 coordinates.
When an altitude or depth is present in the file, you also have to set the unit used (meters or feet).

Importing the file

Just click "OK" to start reading the file. When all parameters were entered correctly, the imported
sounding will appear in the "Project Explorer". 

5.5 Importing Soundings from NMEA0183 log

NMEA0183 Logfiles

This feature allows users to create a sounding directly from a recorded NMEA0183 logile. This can be
used to retrieve data from, for instance a remote controlled survey vessel such as the OcienScience Z-
Boat 1800.
This option can only be used when depth and position data is in the same file.

NMEA0183 Import Tool

To start the NMEA0183 importing tool, select "Import NMEA0183..." from the "File" => "Import" menu as
shown below.
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In order to import data, you have to specify a local map projection first. In case you haven't done so, the
application will prompt you to do this now.
After a map projection has been selected, the following dialog should appear:

NMEA0183 Import Settings
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Filename

Select the filename of the file you want to import. Click the "Browse..." button to select a file. 
After selecting a filename, you can click the "View..." button to check the contents of the file.

NMEA0183 Sentences

Use this settings to select the NMEA0183 sentences used to extract position, depth, heading and
speed from the datafile.
Click the "View..." button to check the file for the best sentences. In most cases the sentences selected
by default will suffice.
When importing position and depth data, the X,Y and Z offsets configured in Hydromagic will taken into
account.
 
Advanced Settings

In order to use only differential or RTK position data, you can use the Quality setting. 
It will discard all position data with a lower quality then the one selected. Please note that this feature is
only supported when the $GPGGA is used for position data.

Use the "Checksum" setting to specify whether the NMEA0183 checksum is computed.
When enabled, all NMEA0183 sentences with an invalid checksum will be discarded.

Starting Import

When everything is setup, just click the "OK" button to start the import. You will see a progress
indicator at the bottom of the screen.
When the sounding has been imported successfully, it will be displayed on the screen.

5.6 Playback Soundings

Introduction

The sounding playback option by Eye4Software Hydromagic can be useful to check recorded tracks, for
demo purposes, or to simulate a real situation to try out the software. You can playback all supported
track formats including: Hydromagic project files, imported ASCII sounding data and GPX files.

Starting the tool

You can start the playback tool by selecting "Playback Sounding" from the "Tools" menu. All loaded
soundings are displayed in this window, just select the track to play, and click the "Start" button. 
You can rewind to the beginning of the track any time by clicking the "Rewind" button. To stop playback,
click "Stop".

The sounding is played using a speed of 1 position per second. You can use the "Increase" and
"Decrease" buttons to change the playback speed. To reset the speed to the default, click the "Default"
button.
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During the playback, the position information of the playback tool is displayed in the "Navigation Data"
display. When a GPS devices is connected, the output of the device is ignored. By closing this tool,
normal GPS reception will be resumed.

During sounding playback, you can record a new sounding from the simulated sounding. 
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6 Singlebeam Processing

6.1 Edit singlebeam soundings

Ways to edit singlebeam soundings

There are scenarios in which you have to modify an existing or recorded sounding. 
This might be needed to remove spikes in depth data, duplicate values and positions without depth data.

In Hydromagic, there are several ways to alter a sounding:

Using the singlebeam editor

Using the singlebeam editor, you can manually insert, remove or add sounding records. 

You can show this editor by right clicking the sounding in the "Project Manager" and selecting "Edit
Sounding...". 

For more information on the singlebeam editor, please refer to this chapter.
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Using the echogram editor

Using the echogram editor, you can easily remove spikes and void values from your sounding 
by selecting single points or a range of points from a graph.

To select this echogram tool, right click on the sounding in the "Project Manager" and select "Edit
Echogram...".

For more information on the echogram editor, please refer to this chapter.

Filtering singlebeam soundings

Using the built-in sounding filter, you can automatically delete invalid sounding values.
This can be done by selecting a minimum and maximum sounding value or deviation to remove spikes.

To select this filtering tool, right click on the sounding in the "Project Manager" and select "Filter
Sounding...".

For more information on the singlebeam filter, please refer to this chapter.
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Edit using the chart display

You can alter sounding via the chart display. You can drag and drop points, or alter depth values using
the context menu.

Make sure the sounding you want to alter is set as active. 
This can be done using the Project Explorer by right-clicking the sounding, and selecting the "Set
Active" menu item.

Activating this menu can be done by right-clicking a depth value or GPS fix on the map as shown below:
It allows you to remove, edit or add sounding values.
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6.2 Singlebeam Editor

Singlebeam Editor

The singlebeam editor is a tool which can be used to manually edit all calculated data points in a
sounding.
You can use it to delete, insert and modify XYZ records.

Starting the editor

You can start this editor by right clicking the sounding to be edited in the Project Explorer, and selecting
the "Edit Sounding..." option as shown below:
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Using the editor

When only a couple of soundings have to be modified, this can be done using this editor. 
When the editor is started, it displays a list of all values in the sounding including position, heading, tide
and other corrections.
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You can modify a value by just double-click it with the mouse. A dialog showing all properties of the
current sounding is shown:
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You can alter the depth, tide and sensor values per record. If you want to alter the low frequency depth
value, select the "Show low frequency values" first.
When done, click "OK" to save the changes, or "Cancel" to discard.

Singlebeam editor toolbar
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The toolbar contains a couple of operations that can be performed on a sounding, like inserting values,
deleting values, splitting soundings and more:
Some of the toolbar's functions can also be used by right-clicking records in the list.

Sorting

To apply operations on more records in a specified range, you can use the sorting functionality.
For instance, when you want to delete all soundings with depths 0.00 - 0.50 meter, you can sort the
records by depth by clicking on the column header.
You can select a range of depths by holding the "SHIFT" key, and selecting the first and last record.

Toolbar buttons

(A) - Edit record

Edits the currently selected record. This is the same as double-clicking an item in the list.

(B) - Add Record

Allows you to add an extra record at the end of the list. This can for instance be used to add a manual
measurement to the sounding.

(C) - Insert Record

Allows you to insert an extra record below the selected records(s) in the list. This can for instance be
used to add a manual measurement to the sounding.

(D) - Delete Record

Use this function to delete one or more selected records from the list. You can select more records by
holding the "CTRL" key while selecting records with  your mouse.
Before deleting, a confirmation dialog is displayed allowing you to cancel the operation.

(E) - Reverse

Clicking this button reverses the direction of the sounding. This means the last record is displayed first.
All headings in the file are rotated by 180 degrees.
This can be used to reverse a sounding before playing it back, or when joining multiple soundings in the
same direction.

(F) - Shift

With the shift function you can apply offsets on one or multiple records using the "Shift Sounding" tool.
With this tool, you can apply offsets to depth, tide and position. It also allows you to reverse the sign,
swap high and low frequency values and more.

(G) - Split
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Allows you to split a track at the selected record. The current sounding will not be altered, instead two
new soundings will be created.

(H) - Empty

This option deletes all records, but not the sounding itself. For instance, if you need to start over, you
can empty the sounding with this button.
Before deleting, a confirmation dialog is displayed allowing you to cancel the operation.

(I) - Reload

Reloads all records.

(J) - Zoom

Zooms to the selected record(s) on the chart display.

(K) - Toggle projection 

Toggles the coordinates between geographic and projected coordinates.

6.3 Echogram Editor

Echogram editor

The echogram editor is used to quickly remove spikes and void data from a sounding.
To start the echogram editor, right click on the sounding you want to modify in the Project Explorer, and
select the "Edit Echogram..." option from the context menu.
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Using the echogram editor

Using the echogram editor is very simple. Just select the data you want to remove and click the remove
button (C).
It is also possible to edit or delete single values using the mouse. You can edit either the low or high
frequency depths with this tool.

Echogram editor toolbar

(A) - Edit value

When this function is selected, clicking a value in the echogram window will open a dialog containing the
properties of the sounding.
You can use this to manually adjust the sounding value (depth) of a single point in the graph.

(B) - Delete value

When this function is selected, clicking a value in the echogram will delete the value.

(C) - Delete selection

After selecting data in the echogram window (for instance a spike or a range of data), click this button do
remove the data.

(D) - Reload

Clicking this button results in resetting any zoom operations and reloading the data in the graph.

(E) - Elevation mode

Switch between elevation mode (height) and depth mode. Clicking this button will mirror the Y axis of the
graph/

(F) - Show all

Undo all zoom operations to show all data in the graph.

(G) - Print

Clicking this button will send a copy of the current view to the printer.

6.4 Filter Soundings

Introduction

The tool discussed in this chapter is designed to filter spikes and zero values from your soundings.
It allows you to enter a minimum and maximum sounding values, as well a maximum deviation from one
sounder ping to the next one.
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For instance, when the depth increases 2 meters within a second, changes are that this is a false echo
received by the echosounder.

Starting the tool

To start the tool, right click on the sounding you wan to filter in the project view, and select the "Filter
Sounding..." option. You should see something like this:

Configuring filter options

Sounding Limits

Use this option to set the minimum and maximum depth limits in the sounding. It is possible to check
only the lower or upper limit by setting the "On Error" setting for the lower or upper limit to "Do Nothing".

When the filter is applied to the selected sounding, it will compare each sounding with the lower and
upper limit specified. If the value isn't between these two limit, the action selected in the "On Error"
selection will be executed:

Delete Sounding The record will be deleted from the sounding.
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Copy Lower Value When the depth value is below the lower limit specified, the record is
set to the lower limit.

Copy Upper Value When the depth value is above the upper limit specified, the record is
set to the upper limit.

Do Nothing The record will remain unchanged, can be used to disable lower and/
or upper limit filter.

Spikes / Deviation

This filter checks the difference between two sounding values in sequence. In case the difference
between these two is to big, it will delete or limit the value depending on the "On Error" setting:

Delete Sounding The record will be deleted from the sounding.

Limit Deviation The deviation will be limited (in other words, the spike will be lowered).

Do Nothing The record will remain unchanged, select this option to disable the
spike filter.

Options

Create a backup This function will create a backup (clone) of the sounding which is
going to filtered. This way, you can always restore the original data on
failure.

Remove zero sounding(s) Removes all zero values from the sounding. Please not that when the
sounding has been corrected, there could be elevations equal to zero
which can be correct.

Generate log With this option checked, a log is displayed showing all operations
performed during the filtering.

Start Filtering

When all options have been configured, just click the "OK" button to start the filtering process. When a
logfile is requested, it is opened after the sounding has been processed:

All settings will be stored, when opening the filter sounding tool the next  time, your preferred options will
already be filled out.
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6.5 Apply Offsets

Introduction

The sounding offset tool can be used to make corrections to a sounding in cases a sounding was
performed with a faulty system configuration, for example when an invalid echosounder offset was used,
or the clock of the PC was set to an incorrect time. 

The offset tool offers the following correction options:

Shift the sounding by a fixed distance and bearing;
Shift the sounding by a fixed northing and easting offset;
Shift the sounding by a fixed longitude and latitude offset;
Applying a fixed depth correction for all depth values;
Applying a fixed tide correction for all depth values;
Reverse the sign for all depth values;
Swap the high and low frequency depth values;
Adjust the starting time of the sounding.

Adjusting the complete sounding

To start using the sounding offset tool to make changes to the whole sounding, you have to start it by
right-clicking on the sounding you want to modify, and select the "Shift Sounding..." option as shown
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below:

Adjusting a selection from the sounding

To start using the sounding offset tool to make changes to one or a couple of (selected) records only,
you have to start the tool from the sounding editor as described below.
First open the sounding editor, by right clicking the desired sounding, and select the "Edit Sounding..."
option. The sounding editor will now appear. Next select the records you want to modify, and right click
the selection.
In the popup menu that appears, select the "Shift Sounding Records..." option as illustrated below:
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Using the sounding offset tool
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Shift sounding by distance and course

When using this option, all positions will be offset in the direction and distance as entered into the
"Distance" and "Course" edit controls.
For minimum distortion, the Vincenty formula is used to calculate the new positions. Depth data remains
unchanged.

Shift sounding by X and Y distance offset

When using this option, all positions will be offset with a fixed x and y value:

Easting (new ) = Easting (old) + X
Northing (new) = Northing (old) + Y
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The offset has to be entered in the units displayed in the status bar of the application (horizontal units).
This option does not alter depth data.

Shift sounding by longitude and latitude offset

Same as the previous option, however this offset is calculated using a longitude and latitude offset in
degrees.
Data is converted from local grid to WGS84, the shift is applied, and the coordinates are calculated back
to local grid.
This option does not alter depth data.

Apply depth correction

This function is very useful when a sounding has been performed with an invalid echosounder offset.
By entering the new offset, all depth data will be corrected. Position data remains unchanged.

Apply tide correction

This function can be used to apply a fixed tide level to the sounding.
It can only be used on waters with small fluctuations in the water level,
for large differences in tide level, you should use the tide correction tool instead.

Invert depth

When depths has to be expressed as negative values (in height instead of depth), you can use this
option to invert the signs.
Most of the times this function is used after tide correction has been applied to the sounding.

Swap high and low frequency depths

When this function is selected, the values of the high and low frequency depths will be swapped.

Adjust sounding start time

When a sounding was recorded using an invalid system time, or when the time is absent, for instance
when the sounding has been imported through an ASCII file, you can use this option to adjust the
starting time of the sounding. Just select the date and time of the first fix in the sounding, all next fixes
will be adjusted accordingly. When using tide correcting, your sounding will have to contain correct date
and time information.

6.6 Tide Correction

Introduction

When recording soundings in tidal area's you have to take in account the current tide level. You can
either enter the tide manually during the sounding, or automated, using a tide receiver or RTK.

It is also possible to correct a sounding afterward by using automatic tide correction. To use this feature,
you have to enter several tide observations. You can enter this data during the sounding, or collect the
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data afterward, for example, using the internet or tidal calculators. 

During Survey

During the survey, in cases where a tide receiver is not available, it is possible to enter the current
waterlevel by hand.

You can enter the value's each time a scale is passed. To enter the current tide value, just click the 
button and enter the value.

Tide Correction

To correct a sounding with tide observations, you have to start the "Tide Correction" tool by selecting
"Tide Correction..." from the "Tools" menu. The following dialog should now appear: 

Adding tide observations

In order to correct the sounding, we have to enter several tide observations. The more observations you
enter, the more accurate the correction will be. 
To start adding observations, please click the "Enter..." button. The following dialog is shown: 
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By clicking the "Add..." button, you can start entering observations. Make sure the date and time are
entered correctly, otherwise these observations will be ignored. You can use the "Edit..." and
"Remove..." buttons to make corrections. When all values have been entered, click "OK" to return to the
previous window. 

Applying tide correction

You can now apply the correction by clicking "OK". When the "Show Correction log" function is checked
(recommended), a notepad window will popup containing all the sounding values and their corrections.
Please double check this for errors. 
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7 Post Processing

7.1 Generate and Display Matrix

Introduction

In Hydromagic, a matrix is a collection of regularly spaced depths, which can be projected over the map
as color or text. 
This is also known as a digital terrain model or DTM.

During the generation of a matrix from a sounding, the scattered data points are converted to regularly
spaced 
data using a TIN (Triangulated Irregularly Network). This TIN is generated using a Delaunay triangulation
algorithm.

All new data points are generated by "filling" the triangles, which have been formed from the scattered
data. 
The image below shows a color matrix which has been generated using TIN (data points at 0.25 meter
interval). 

Generating a matrix

To generate a matrix, you must have loaded either a valid sounding or a shoreline containing depth or
height information. 
Without sounding or shoreline data, it is not possible to generate a matrix.

In order to generate the matrix, you have to specify some settings. 
To do so, open the "Generate Matrix" dialog by selecting "Generate Matrix..." from the "Tools" menu:
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Sounding data

Select from which sounding(s) you wish to generate the matrix. By clicking the "Select..." button, you
will be able to select one or more 
soundings that will be used to calculate the triangulation from which the matrix or digital terrain model
will be generated.

Shoreline data

Select which shorelines you wish to include in the matrix calculation. 
Shorelines can be used to append extra data near the shoreline, or to clip the matrix data along the
shore.
For more info on how shorelines can be used, please refer to the chapter "Entering Shoreline Data'".

Sounding channel

You can use  this setting to select which data of the sounding is used to generate the matrix.
This can be one of the following values:

Depth recorded with the low frequency channel of your echosounder;
Depth recorded with the high frequency channel of your echosounder;
The difference in depth between the high and low frequency channel (Low - High);
The difference in depth between the high and low frequency channel (High - Low);
Sensor data channel 1;
Sensor data channel 2;
Sensor data channel 3;

The sensor data channels can be used to store either magnetometer data, information on reflectivity,
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bottom loss or duration of the returned echo(s).
The data that each channel contains can differ, and depends on the echosounder plugin that was used
to record the data.

Matrix spacing

You can select the spacing of the regularly spaced data here. The same spacing is applied to both the X
and Y axis. 
The spacing has to be entered in the same units as used for the map projection.

Which spacing to use depends on the zoom scale you are using. For an overview of a large area, you
can use 2.5 meter. 
When zooming in on a smaller area, the best is to use values between 0.25 and 1.00 meter. 

Please note that when using a larger spacing, it will be generated and displayed faster then a more
dense matrix.

Clipping area

Use this to select which clipping area (boundary) has to be applied when generating the matrix. Only
data points within this area will be calculated. 
This can be used in cases when only a part of the sounding areas has to be interpolated.

In addition to boundaries, you can also use shorelines to clip data along the shore, or to generate
islands (or holes).

Output file name

Enter the name of the file that is generated here. This setting is required. 
You can enter a simple name (for instance the same name as the sounding used) here, which will be
stored in the default matrix folder. 
When you want to store the result elsewhere, use the browse button to select the output folder and file
name. 
The data will be added to the current project and stored in a separate ASCII XYZ file at the desired
location.

Generating the matrix

Finally, click the "OK" button to start the process. It should take a couple of second, you can watch the
progress in the status bar of the main window. 
After generation, you will notice the matrix has been added to the project. Depending on the
configuration, the newly generated matrix will be drawn over the map. 

Displaying the matrix

There are more ways of showing the matrix on the map. In the example near the top of this page, it is
displayed at both colors and text at a 5x5 meter interval. 
It is also possible to not show it (and just use the matrix to export data), to show it with colors only
(using the defined color ranges) or to show its depths as text.

To change settings on how the matrix is shown, select "Preferences..." from the "Options" menu, and
select the "Matrix" tab. 
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A dialog with all matrix settings will be displayed. It should look like the screenshot below:

Display as colors

The first section is to enable or disable the color overlay, and to specify which colors to use for the
different depths. When checking the "Display matrix as colors" option, the matrix is displayed as colors
on the map. The "Colors..." button will also be enabled, so you can start creating the color ranges for
your sounding.

After clicking the "Colors..." button, the following dialog will appear:
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In this dialog, you will be able to add, remove or modify colorranges by clicking one of the buttons at the
bottom of the list. To change a range, just double click on it, and change the settings. In case you want
to store the color scheme you designed for other projects, you can store it in a separate XML file using
the "Save..." button. Just use the "Load..." button in the other project to retrieve this scheme.



Post Processing 155

© 2013 Eye4Software B.V.

It is also possible to create a color scheme using a min, max and step value. To do this, select the
"Auto..." button, and select the lower and upper range, next specify the interval between the ranges. 
This tool will generate max 20 ranges, so it is important to choose the correct interval.

Display color legend

The second section contains the settings for the color legend which is displayed as map overlay when
colors are displayed. You can turn it on or off here.

Display depth as text

The third sections contains the settings for drawing the matrix as text. Depending on the size of the
spacing, you have to adjust the text intervals in a way that the text's on the map do not intersect. 
Using the check box you can enable and disable depths in text. 

7.2 Generate Matrix from Sections

Generating a reference matrix from sections

A reference matrix that can be used to perform volume calculations can be created from:

a recorded sounding;
collection of sections, also known as channel design;
a vector chart which contains 3D vectors.

Channel Design

When comparing the matrix created from a sounding with a matrix created from a channel design, we
can calculated the amount of material which has to be (re)moved in order to get the result as in the
channel design.
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Generate the matrix

To start creating a matrix from the channel design, right click on the "Sections" folder in the "Project
Explorer" and select the "Generate Matrix..." options as shown below:

After selecting this option the "Generate Matrix from Sections" will be displayed, as shown in the image
below:
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Sections

Select which sections you want to include in the matrix calculation. In most cases you select all
sections, which can be done by clicking the "Select All" button.
To deselect all sections, click the "Select None" button. To select only section that are set as visible in
the project, click "Select Visible".

Spacing

Set the required spacing. Please note that when using the volume calculation using matrices, this
spacing should be equal to the one used in the matrix generated from the sounding.

Clipping Area

Select which area or boundary will be used to indicate the clipping area of the matrix generated from the
sections. This value is required.

Filename
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Click the "Browse..." button to select a folder and file name for the generated matrix. The matrix is saved
as an ASCII file containing all the XYZ pairs calculated by this tool using TIN.

Projection

To save the XYZ data in a different projection then the current one, click the "Select..." button to change
the projection.
Coordinates will be converted during saving to the output file.

Starting generation

When all parameters has been set, the matrix will be calculated and added to the project.
During the generation process, a progress bar will be shown in the status bar.

When finished and loaded, you will see something similar to the image below:

7.3 Generate Matrix from CAD

Generating a reference matrix from CAD or vector maps

A reference matrix that can be used to perform volume calculations can be created from:

a recorded sounding;
collection of sections, also known as channel design;
a vector chart which contains 3D vectors.

CAD drawing

This is perhaps the easiest way to create a reference matrix (DTM), provided that an AutoCAD or
MicroStation CAD drawing of the area is available (and of course, contains elevation information).
From the vectors collected from the CAD file, a TIN model is generated and heights are calculated on the
generated triangles.
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When comparing the matrix created from a sounding with a matrix created from a CAD drawing, we can
calculated the amount of material which has to be (re)moved in order to get the result as defined in the
CAD drawing.
A sample CAD design of how to construct a basin is displayed below:

Generate the matrix

To start the conversion, right click on the loaded DXF or DGN CAD file, and select the "Export to
Matrix..." option.:
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Vector Map

Use this control to select the vector map to generate the matrix from. Please note that only vector maps
are displayed here, raster maps do not contain elevation information.
By default the "Active Layer" is selected in this control.

Layer Filter

Enter the names of the layers that should be included in the calculation. To enter multiple names, just
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separate them using semicolons.
This field is required, when left blank, there will be no generation of matrix data.

Spacing

Set the required spacing. Please note that when using the volume calculation using matrices, this
spacing should be equal to the one used in the matrix generated from the sounding.

Clipping Area

Select which area or boundary will be used to indicate the clipping area of the matrix generated from the
sections.
When you want to disable clicking, select the default option "<No Clipping>".

File

Click the "Browse..." button to select a folder and file name for the generated matrix. The matrix is saved
as an ASCII file containing all the XYZ pairs calculated by this tool using TIN.

Starting generation

When all parameters has been set, the matrix will be calculated and added to the project.
During the generation process, a progress bar will be shown in the status bar.

When finished and loaded, you will see something similar to the image below:
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7.4 Generating Contours

Introduction

Contour lines are lines connecting points with the same depth, height or other data. 

During the generation of contour lines from a sounding, the scattered data points are converted to
regularly spaced 
data using a TIN (Triangulated Irregularly Network). This TIN is generated using a Delaunay triangulation
algorithm.

After this step, Hydromagic calculates the contour lines by determining the positions where the depth
contour crosses the calculated triangles.
All these lines are connected to each other, and stored as a vector layer, which can be exported as
either an ESRI shape file or AutoCAD DXF file.

Creating Contours

To generate contours, you must have loaded either a valid sounding, or a shoreline containing depth or
height information.
Without sounding or shoreline data, it is not possible to generate depth contours.

Soundings without valid depth or elevation data will be ignored. If you want to clip the generation of
contours to a specific area, you should have created or loaded a boundary as well.

Open the "Generate Contours" tool, by selecting it from the "Tools" menu. The following dialog will
appear:
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Sounding data

Select from which sounding(s) you wish to generate the depth contours. By clicking the "Select..."
button, you will be able to select one or more 
soundings that will be used to calculate the triangulation from which the depth contours will be
generated.

Shoreline data

Select which shorelines you wish to include in the depth contours calculation. 
Shorelines can be used to append extra data near the shoreline, or to clip the depth contours along the
shore.

For more info on how shorelines can be used, please refer to the chapter "Entering Shoreline Data'".

Sounding channel

You can use  this setting to select which data of the sounding is used to generate the contours.
This can be one of the following values:

Depth recorded with the low frequency channel of your echosounder;
Depth recorded with the high frequency channel of your echosounder;
The difference in depth between the high and low frequency channel (Low - High);
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The difference in depth between the high and low frequency channel (High - Low);
Sensor data channel 1;
Sensor data channel 2;
Sensor data channel 3;

The sensor data channels can be used to store either magnetometer data, information on reflectivity,
bottom loss or duration of the returned echo(s).
The data that each channel contains can differ, and depends on the echosounder plugin that was used
to record the data.

Clipping area

When a clipping area has been specified (by using a earlier created boundary), the contour lines will be
clipped at the point they cross the polygon of the boundary. 
This way it is possible to only generate contours in a specified area. When the "No Clipping" option is
selected, there will be no clipping and the contours will cover the entire area of the sounding.

In addition to boundaries, you can also use shorelines to clip shorelines along the shore, or to generate
islands (or holes).

Contour levels

You can generate contours using a fixed level, or use color ranges. You can also combine the two
options. Using a fixed level can be useful, to display a reference line (for instance the dredging depth) to
see what's above and below this line. When using the color ranges, the levels displayed as colors will be
accentuated.

Contour smoothing

When generating depth contours from a TIN model containing large triangles, it happens often that sharp
edges appear in the contour lines.
To make the lines look more pleasant for the eye, you can enable the "Use contour smoothing" option to
use a B-Spline algorithm to smoothen the lines.

The level settings allows you to set the degree of smoothing. When using level 1, just a little bit of
smoothing is applied, while level 9 applies the most.
A good value to start with is level 5. When contours are starting to cross, you might want to try a lower
level.

Layer name

The layer name can be edited to allow you to create multiple layers, for instance, a separate layer for
different fixed levels. Using the project manager, you can select which contours are visible or not.

File name

The generated contour lines can be directly written to an ESRI shape file. To do so, enter a file name
into this box. When the contour is not written to a shape file, it is volatile and will be lost once the
project is closed and reloaded.

Finish

When all settings are correct, click the "OK" button to finish the process. The software will now create
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the TIN model, and generate the contour lines. You will have to wait a couple of seconds, depending on
the number of records your sounding contains. When ready, the dialog will disappear, and the contours
are drawn on the screen.

Managing Contours

Show / Hide contours

To temporary hide or show a collection of contour lines, just click the "eye" icon in front of the contour
name. 
When hidden, the contour is still loaded, but just not shown on the screen.

Delete contours

To delete a collection of contour lines, look for the name in the "Project Explorer" and right click on it. 
Select the "Remove Map..." option from the popup menu, and confirm the action.

Export contours

Even when you choose to not save the contours when creating, it is possible to export them afterwards. 
From the "File" menu, select "Export", then select the "Export Vector Data" option:
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7.5 Volume Calculation (Matrix)

Volume calculation using matrix

The matrix volume calculation tool can be used in two ways: to calculate the difference in volume
between two matrices (for instance, pre-dredge and post-dredge), or between a matrix and a fixed level. 

This last option can be used to calculate the area and volume of a pond or basin or tank. In order to use
this option for volume calculation, make sure you have converted your corrected sounding to a matrix
(see chapter "Generate and Display matrix" ).

This tool calculates volumes by multiplying the difference between depth in matrix 1 and matrix 2 with
the size of a single cell (Spacing).

Volume calculation tool

To start the matrix volume calculation tool, select the "Volumes (Matrix)" option from the "Tools" menu.
The following dialog will be shown:
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Matrix 1

Use this setting to specify the matrix created from your sounding, or when using two matrices, the
matrix created from the post-dredge sounding.

Matrix 2

Use this setting to specify the matrix created from your pre-dredge sounding or a matrix created from a
3D cad file or channel design.

In case you are calculate the volume of a basin or pond, select the "<Use Fixed Level>" option, and
enter the level of the water surface. When no tide correction is used, this value is 0.00.

Totals

This section will display the total area and volume for the whole sounding.
The processed area means the amount of overlap between the two matrices used.

When a fixed level is used, the overlap is always 100% and the processed area will be the same as the
total area.
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Below Reference

Area and volume below the level found in Matrix 2

Above Reference

Area and volume above the level found in Matrix 2

Calculate

Click the "Calculate" button to calculate area's and volumes from the selected matrices.
Calculated values are split in totals, above reference (Matrix 2) and below reference (Matrix 2).

Report

Click the "Report" button to calculate area's and volumes from the selected matrices.
This function creates an ASCII file containing a detailed report on the calculated volumes, which can be
saved or printed.
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7.6 Entering Shoreline Data

Shoreline Data

The shoreline data option can be used to enter depth data for places you cannot reach using your
vessel, for instance, because the water is to shallow.
It can also be used to specify a line of equal depth, for instance where the water reaches the shore.

For instance, in the example below, you would set the depth for all points on the line to zero:

Drawing a shoreline

In order to draw a shoreline using hand, for instance when it is possible to use a accurate map, select
the "Draw Shoreline" option from the "Cursor" menu.
Now you can click the points that make the line segments for the shoreline. When finished, just click
the right mouse button to store the line.
Shorelines will appear as green lines on top of your background map(s).
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Entering Manually

When you want to enter the shoreline manually, for instance when you have measured the shoreline
coordinates from the shore using a RTK rover, right click on "Shorelines" in the "Project View" and
select "Add Shoreline".
The following dialog should now appear, allowing you to enter all measured coordinates in the
spreadsheet. Click the "Add..." button to add new records.
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Setting depth values

When the shoreline connects points with the same depth value, for instance zero, you can set all Z
values at once by clicking the "Level..." button and entering the value.
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Modifying shoreline data

To modify the positions in shoreline data, you can use the mouse to drag and drop the positions on the
map.
When you want to modify positions manually, or you want to alter the depth values, you have to use the
"Edit Shoreline" dialog.
To open this dialog, right click on the shoreline you want to modify in the "Project View" and select the
"Edit Shoreline..." option.



Eye4Software Hydromagic174

© 2013 Eye4Software B.V.

Applying shoreline data

Shoreline data can be used when generating matrices, and thus also calculating volumes (using
matrices).
When generating a matrix, you can specify which shorelines you want to include by clicking the
"Select..." button.
In the dialog that appears, check the shorelines you want to include and click "OK":
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7.7 Export to Google Earth

Introduction

KML (Keyhole Markup Language) is an XML format used by Google Earth to load overlays. KML can
contain point, poly line and polygon data, as well as one or more references to raster overlays. It is also
possible to script complete Google Earth presentations into a KML file. 

At this moment, Eye4Software Hydromagic supports point, line and polygon features, as well as
attributes, styles and ground overlays. Eye4Software Hydromagic is able to both import and export
Google Earth KML files. This document describes how to export them.

Exporting Data

In Hydromagic, it is possible to convert tracks, vector maps, matrices, boundaries, comments,
waypoints and sections to KML files.
When exporting a matrix, an image file is generated and loaded in Google Earth as a so called "ground
overlay".

To start exporting data, select the "Export KML Data" from the "File" => "Export" menu as shown below:

Selecting data to export
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In the dialog that appears, you will see a list of all items that can be converted to KML.
Just check the items you wish to export. By default, all visible items are selected. 
To reset the selection, click "Select None", to select all items, click "Select All".

Select output file

The next step is to select a location to store the exported data. You can save the data as KML or KMZ
file. Click the "Browse..." button to open a save file dialog, and enter the name for the file. In the save file
dialog, you can also choose between the "KML" or "KMZ" formats.
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KML Format

When using the KML file format, a KML file is generated as well as an image file (PNG) for each
exported matrix. The image files are stored in the same folder as the location of the KML file.
When not exporting matrices or large amounts of vector data, KML is probably the best option for you.

KMZ Format

If you are going to export matrices, or large amounts of vector data, KMZ is the best choice. 
A KMZ file is a zipped archive containing a main KML file (doc.kml) and, in case of exporting image data
such as matrices, some image files.
When using the KMZ file format, you can always transfer the data by distributing a single KMZ file.

Exporting the data

Just click "OK" to start the export. For small files, this takes only a couple of seconds, for large projects
it can take a couple of minutes. You can watch the progress in the status bar at the bottom of the
screen. 

Examples of exported KML files
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Example of a single matrix exported as KMZ file
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Example of a single matrix with vector chart exported as KMZ file

7.8 Export to CAD

Introduction

After a sounding has been completed, it is possible to export both the background map (vector maps
only), and the regularly spaced soundings (matrix) to an AutoCAD DXF file for further processing.
AutoCAD DXF files can be opened using AutoCAD, or you can use other CAD software such as QCad,
or import the data in other GIS packages.

After you have created a matrix of your sounding, sections or map, you should have something like this:
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Starting the DXF Export tool

The DXF Exporting tool can be started by selecting the "Export" => "Export DXF Data" from the "File"
menu.
The following window should appear:

Map
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The background map can be selected using the first selection box. You can also choose to export only
the depth information by selecting the "Do not export a map" option.
Please note that not all background maps can be exported to AutoCAD DXF. Only vector charts like S57
ENC, ESRI ShapeFile, DXF, Microstation DGN and ARC/INFO can be used.

Matrix

The matrix can be selected using the second selection box. In case you want to export the map only,
you can select the "Do not export matrix" option here.

Filename

In the third input field, you have to select the file name of the CAD file to be generated. This file should
be a valid file name at an accessible location with the extension ".DXF".

Options

When your background map contains a lot of text, it is recommended to turn off the "Export Map Texts"
function, to prevent the map text from interfering with the depth values.

If needed, you can write the DXF file using another local grid by changing the grid displayed at the
bottom of the window. By default, the current local grid is used.

Starting the export process

When all parameters are setup correctly, click "OK" to start the export. A progress indicator will appear
at the bottom at the screen, and the window will close after a couple of seconds.
You can now open the DXF file in most CAD programs, it is also possible to use the generated DXF file
as a background map in Hydromagic.

Opened in a CAD editor, the result will be (depending on your settings):

Opened in QCad
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Opened in Hydromagic

7.9 Export current view

Introduction

Using the Eye4Software GPS Mapping Studio, it is possible to save your current map view (including
overlays like tracks, photos, comments, waypoints and routes) as an image file. The software can also
generate the world and projection files for you, so you will be able to load the image file directly in other
GPS or GIS mapping software, without the need to calibrated the map. For exporting, the following
vector map formats are supported:

    Graphics Interchange Format;
    Portable Network Graphics;
    JPEG Image Files;
    Tagged Image Format Files;
    Windows Bitmap Files.

Loading the source data

In order to load the map, used as background, select "Import" => "Import Map..." from the "File" menu.
Because the map is just exported as an image file, all formats can be used. Please not that attribute
information is not saved on export, because a simple image format is used.

After loading the map, you can add overlays, like photos, comments and waypoints. To import such
overlay data, select "Import" => "Import GPS Data..." from the "File" menu. 

Hydrographic data such as soundings, matrices, cross sections and boundaries will also be visible in
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the exported final product.

Exporting the view

In order to export the current map view, select "Export" => "Export Current View..." from the "File"
menu. 

Export Current View Dialog

After a few seconds (needed to capture the image), the following dialog will appear: 
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Output file

First, you have to select the output format and the filename of the image file. After selecting the format,
use the "Browse..." button to select the folder and file name.

Generate World File

In cases where you want to import the exported image file into another GPS or GIS mapping software
product, you have to enable this option. The software stores the upper-left coordinates and the pixel
sizes (scale) in the world file. Depending on the image format you are using, the world file will have the
following file extension:

    GIF World File - gfw;
    PNG World File - pgw;
    JPG World File - jgw;
    TIF World File - tfw;
    BMP World File - bpw;

3.726715

0

0

-3.726715

242435.599588

476855.346680

sample world file

Projection Files

The software can generate a ESRI WKT or PROJ.4 projection file for you. Together with a world file for
geo-referencing the image, this enables the screenshot to be imported in most GPS/GIS software
packages.
The generated projection file will always have the ".prj" extension, irrespective of the selected format.

PROJCS["Amersfoort / RD New",

    GEOGCS["Amersfoort",

        DATUM["Amersfoort",
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            SPHEROID["Bessel 1841",6377397.155,299.1528128,

                AUTHORITY["EPSG","7004"]],

            AUTHORITY["EPSG","6289"]],

        PRIMEM["Greenwich",0,

            AUTHORITY["EPSG","8901"]],

        UNIT["degree",0.01745329251994328,

            AUTHORITY["EPSG","9122"]],

        AUTHORITY["EPSG","4289"]],

    UNIT["metre",1,

        AUTHORITY["EPSG","9001"]],

    PROJECTION["Oblique_Stereographic"],

    PARAMETER["latitude_of_origin",52.15616055555555],

    PARAMETER["central_meridian",5.38763888888889],

    PARAMETER["scale_factor",0.9999079],

    PARAMETER["false_easting",155000],

    PARAMETER["false_northing",463000],

    AUTHORITY["EPSG","28992"],

    AXIS["X",EAST],

    AXIS["Y",NORTH]]

sample ESRI WKT projection file

Exporting the map

Just click "OK" to start the export. The software will now write the selected files. You can monitor the
progress in the status bar at the bottom of the screen. Depending on whether you checked the "Show
image after export" the created image will be shown in the Windows Photo Viewer. 
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